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Introduction
Dear User,

Thank you for choosing inPhoto ID Webcam!

inPhoto ID Webcam is an application for identification photo preparation with control functions

webcam or any devices having webcam interface. inPhoto ID Webcam allows you to manage and

to automate the whole cycle of ID photo preparation. The program takes over full webcam control,

quickly and accurately detects a face on image, build and crop frame in accordance with user`s

settings, save image in a folder or transfer to applications supporting the TWAIN protocol (Adobe

Photoshop, Incardex, Asure ID, CardFive, ID Works, EPISuite и др.). inPhoto ID Webcam also has

the ability to connect external tools and automatically execute additional actions needed on the

processed identification image. For example, you can send the prepared ID photos by e-mail

automatically.

Main features:

Webcam control, image capturing and identification photo preparation are the main functions of 

inPhoto ID Webcam. You can also manage the shooting process with voice commands.

"Live" Preview allows you to see how will look the processed photo. The preview shows "live"

image in real time. All changes of webcam settings, the frame building settings and image resolution

settings are displayed in the preview immediately. 

Face detection and Crop settings allow to find the face area on image and to crop on this basis

the future ID photo in accordance with user`s settings. For building frame, the program takes such

image parameters as follows: size, dimensions, target person’s position, type of frame etc.

Image Correction allows adjusting image brightness, contrast, gamma, and sharpness to obtain the

greatest result. All changes of the correction settings for processed image may be seen on the

preview.
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TWAIN image capture allows transfer of prepared identification (ID) photos via TWAIN protocol

directly to the target applications. The TWAIN protocol is supported by such apps as: Adobe

Photoshop, Incardex, Asure ID, CardFive, ID Works, EPISuite etc.

Save to File allows you to save acquired images to file and set desired file name and folder

manually or automatically. The file name consist of a prefix entered by the user, the shooting date

and image number. The folder may include the current date that allow to create an easy-to-use

archive of electronic images located on the disk.

External tools connection allows to connect an external app to inPhoto ID Webcam to

automatically execute required additional actions with the processed images without interim saving

or any other actions by the user. Such feature is used to automatize identification photo preparation

as much as possible.

We hope that this guide will help you quickly familiarize yourself with the program and make use of

the full range of its capabilities.
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Chapter 1. Start of Work
The contents of the chapter are as follows:

Installation

Start-up

Activation
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Installation
The inPhoto ID Webcam application is being installed on a computer online using the installation

wizard.

Run the installation package file (a file with exe extension) to start the installation process.

Step 1. Select the language of the application interface in the window appeared and press OK.

Step 2. In the next window, the wizard recommends you to close all the active applications. This will

enable the application to update system files without restarting the PC. Press Next to continue the

installation. 



inPhoto ID Webcam

8

Step 3. At this step, you should read the licence agreement. Read it carefully and press I agree if

you agree with all the clauses. Once this is done, the installation of the application will continue. If the

licence agreement is not accepted, the installation will be cancelled.
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Step 4. At next stage, the wizard offers selecting a folder to which the application will be installed.

Press Install to start installing the application.
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Step 5. Then, the application installation window will appear. The installation process may take some

time. Please wait until it has completed. After the installation has completed, the wizard will

automatically move to the next step.

Step 6. The next action the wizard will offer creating a desktop shortcut for the application. The

application shortcut is added to the Start menu and to the list of TWAIN drivers in any case during

the installation. If you also wish to add the shortcut to the desktop, press Yes, if the shortcut in the

Start menu is enough, press No.
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Step 7. This is the last step of the wizard. Here it informs you that the application has been installed

on the computer. Press Finish to complete the installation.

Done! inPhoto ID Webcam has been installed. Run the inPhoto.exe application file to start working

with the application.

The next Start-up chapter describes how to start up inPhoto ID Webcam.
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Start-up
inPhoto ID Webcam can be started in several ways:

1. Starting up inPhoto ID Webcam from Start Menu.

For doing this, enter the Start menu -> All Apps -> inPhoto ID Webcam  group menu and choose

inPhoto ID Webcam.



Chapter 1. Start of Work

13

2. Starting up inPhoto ID Webcam from the Desktop.

This start-up option is possible if you have chosen to add the desktop shortcut for the application

during the installation. In such a case, just find the shortcut on the desktop and double-click it using

the left mouse button.
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3. Starting up inPhoto ID Webcam from the Application Folder.

Open the folder to which the application has been installed (this is C:\Program Files\inPhoto ID

Webcam by default) find inPhoto.exe and start up it by double-clicking.

4. Starting up inPhoto ID Webcam via TWAIN Connection. 

inPhoto ID Webcam can also be started using a third-party application via TWAIN connection. This

mechanism is described in more details in the Process to TWAIN chapter.
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Activation
When starting up inPhoto ID Webcam for the first time, the activation wizard window will appear.

Here you can choose to:

· Use the application in demo mode

· Purchase the licence

· Activate the licence

· Close the application

All other details on using the application in the demo mode and on purchasing the licence are

described further in the Demo Mode and Purchase of the Licence chapters.

If you have already purchased the licence, its activation will confirm the authenticity of the installed

copy and open access to all the application features.

There are two ways of licence activation: Online and Offline. If the Internet connection is available

on the PC where the application is installed on, the Online activation will be selected automatically; if

not, then use the Offline activation. The activation procedure is described in details further in the

Activation Online and Activation Offline chapters.
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The contents of the section are as follows:

Demo Mode

Purchase of the Licence

Activation Online

Activation Offline
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Demo Mode
The user has access to all the application features in the demo mode.

There is a limitation: all received images will contain a demo sign.

The demo mode allows trying the application at work and assessing its capabilities before

purchasing. 

To start up the program in demo mode, press the Continue with Demo button.
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Purchase of the Licence
If you wish to activate the application, but have not purchased the licence yet, choose the Buy

License button.
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After that, the application will forward you to the developer's website where you can buy the licence to

the required product.
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Activation Online

 This way of activation requires Internet connection.

Upon initial launch of inPhoto ID Webcam, an activation wizard window appears. Press the Activate

button to start activation of the application.
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Please verify the name of the application being activated is the same as the name of the application

indicated with the Serial Number.

Then enter the Serial Number and press the Activate button.



inPhoto ID Webcam

22

After that, the application will attempt to connect to activation servers. Several servers are made

available for ensuring the reliability of connection. If the PC is connected to Internet and the

connection succeeds, the activation of the application is completed. The activation wizard will inform

you about it with the following message:

If the PC is not connected to Internet, Offline activation window will appear.
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Activation Offline
If the PC on which inPhoto ID Webcam is to be activated is not connected to Internet, then make

use of the Offline activation. In such case, Serial Number validation is carried out via server,by the

same way as when the Online activation used. The difference is that you may use any PC or device

with Internet connection for sending the Serial Number. It is not mandatory to be the PC inPhoto ID

Webcam has been installed on. For example, a user having no access to Internet from his/her job

computer may activate the application using a phone or home computer. There are no constraints as

to the time between sending the Serial Number to the server and entering the received reply code in 

inPhoto ID Webcam activation window. This can be done within any time period.

Upon initial launch of inPhoto ID Webcam, an activation wizard window appears. Press the Activate

button to start activation of the application.
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Please verify the name of the application being activated is the same as the name of the application

indicated with the Serial Number.

Then enter the Serial Number and press the Activate button.
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In the appeared window, please write down or copy the data from the Serial Number and Activation

Code fields. These data are to be sent to the activation server. It is to be recalled that there are no

constraints as to the time between sending the data to the server and entering the received reply

code in inPhoto ID Webcam activation window. You may complete the Offline activation at your

convenience.
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You will need Internet connection to proceed with the activation.

Use your browser to open the page specified in the field 2. From any computer with an Internet

connection, open the activation page.

text
You can open the activation page on any Internet connected device: a laptop, a tablet, a

smartphone, etc.
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Enter your Serial Number and Activation Code in the corresponding fields of the appeared form.

Please note: the data should be entered in the same format as they have been presented in the

activation wizard window, i. e. by groups of 4 digits without spaces, separated by hyphens. 

After having completed the input, press the ACTIVATE button.
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After that, the Authentication Code will be generated. Write it down or copy for subsequent entry into

the activation wizard field.
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If the data are entered incorrectly, the Authentication Code will consist only of zeros. In such case,

please check correctness of the data and the input format. Please note, your Serial Number and

Activation Code should be entered by groups of 4 digits without spaces, separated by hyphens.



inPhoto ID Webcam

30

Enter the received Authentication Code in the field 4. Enter your Activation Code and then press

the Activate button.
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Now, the Offline activation is successfully completed. The application will inform you about it with

the following message:
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Chapter 2. Interface
The contents of the chapter are as follows:

Main Window View

Interface Setting

Shorcuts

Work Completion



Chapter 2. Interface

33

Main Window View
The main window of inPhoto ID Webcam is the user’s interface composed of six main elements.

The user can set the application window according to his/her needs and convenience.

Let's take a closer look at each of these elements:

Window Title

Main Menu

Preview

Side Menu

Status Bar
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Window Title
The title of the window traditionally contains the application name and Minimize, Change window

size, and Close buttons.
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Main Menu
The main menu is designed for accessing different application functions.

The File menu contains general application settings, interface settings, image processing settings,

resulting image saving settings, external tools connection settings and voice control settings.

The View menu contains main window interface settings and webcam settings.
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The Camera menu contains Update AE/AF command, processed image capture to TWAIN, a file

and a clipboard commands, as well as webcam selects and reconnects commands.

By default, the Capture to TWAIN menu item is disabled. You need to establish connection with

TWAIN driver to enable it. For more details on image capture options, please see the Processing

chapter.

For more details on operations with webcam, see the Camera chapter.

The Live View menu contains image rotate commands and tools for configuring snapshot in the

preview area. More information about the menu commands  you can be found in the Preview

chapter. 
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The Help menu contains help topics, update checks, application information and the function of

sending an error report to the product developers.

The Admin menu contains security settings of the application and functions for working with profiles.
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Preview
Under inPhoto ID Webcam, we have implemented a "live" preview of the image before shooting. The

webcam image is displayed in the preview area.

text
 Hereinafter, the preview area will also be referred to as "preview". 

The effect of any change of webcam and crop frame settings will be immediately applied on the

preview. Thereby, the user can monitor composition and quality of the image before shooting.

Please refer to the Preview chapter for more details on the preview operation.
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Side Menu
The side menu is created to bring additional convenience to the application interface and for a

quicker access to the frequently used functions.
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The appearance of the menu depends on the interface settings located in the File menu > Options

> General tab > User Interface Settings section.

By default, the interface is set in such a way that not all, but only the most frequently used buttons

are displayed in the menu.
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text
Please note that the Capture to TWAIN menu item is originally disabled. You need to
establish connection with the TWAIN driver to enable it. For more details on image capture
to TWAIN, see chapter Capture to TWAIN.

Let's take a closer look at the functions of each button.

The Capture to TWAIN, Capture to File and Capture to Clipboard buttons run shooting and

processing of the image.

text
By default, the Capture to Clipboard button is hidden. To make the button visible, please
enter the File menu > Options > General tab and set the Show Capture to Clipboard
button setting. 

The Capture to TWAIN, Capture to File and Capture to Clipboard buttons run the image

processing process with subsequent saving of the results. Actions started with the buttons differ only

by locations to which the processing results will be saved. Capture to TWAIN saves the processed

image to the application with which the connection is established through the TWAIN driver. If the

connection through the TWAIN driver is not established, the button will not be active. Capture to File

saves the processing results to the specified place on the drive. Capture to Clipboard saves image

to the clipboard.

You can read more details on the image processing methods in the Processing chapter.
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The Rotate Right and Rotate Left buttons are provided to rotate the image 90 degrees to the right

or to the left.
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The Update AE/AF button updates auto focus and auto exposition of the camera.

Please refer to the Update AE/AF section for more details.
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The Camera Settings button starts a dialogue window which contains webcam properties.The

dialogue is a part of the camera driver. The Camera Settings button allows you to launch the driver

and configure the webcam directly from inPhoto ID Webcam.

You can get more details on setting the webcam properties in the Camera setting section.
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The Camera Format button launches a dialogue which contains available resolutions for the

webcam.
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The Processing settings button calls up the ID Image Processing dialogue that contains all the

settings regulating image processing: face detection settings, bounding box and subsequent framing

settings, correction settings, resulting image size settings. In addition, a preview area is also

provided in the dialogue; the preview allows you to see the image after processing with the current

settings.

You can read more details on the ID Image Processing dialogue in the ID Image Processing

dialogue section.
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The Profile button calls up the menu consisting of the list of all profiles created in the application and

the Reset profile item. The menu allows applying or cancelling the profile for the current application

session. To apply the profile, just select it from the list. Then, the name of the specified profile will be

displayed on the Profile button. To reset the profile, choose the Reset profile item from the menu.

After that, the profile name will disappear from the Profile button. If the Reset profile item is not

available in the menu, the profile for the current application session is not set. More details on

working with profiles may be found in the Profiles chapter.
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Close button closes the application or minimizes it to tray depending on the status of the Hide to

tray instead of close setting. More details on closing the application may be found in Work

Completion chapter.
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For your convenience, the side menu interface in TouchScreen devices may be made button-

operated. For this purpose, enter the File menu> Options > General tab and enable the Enable

Touchscreen controls setting.
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Status Bar
The status bar is meant for displaying information needed in the course of work. This area is divided

into four sections.

 In the first section, from left to right, the name of the webcam currently connected is displayed.

text

Please note that in the status bar, after shooting, the webcam name will not be displayed.
To re-display the webcam name in the status bar, launch the Reconnect command,
located in the Camera main menu. 

The second section displays the source image dimensions in pixels which are to be received by the

application from the webcam. The dimensions of the source image can be modified by changing

webcam settings.

The third section displays the image dimensions in pixels in the preview. If you resize the application

window, the volume of the current image will also change.

The fourth section displays the scale which is a ratio of the image dimensions in the preview to the

image dimensions from the webcam.
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Interface Setting
The setting of main window interface in inPhoto ID Webcam is flexible. The user can choose view

and scale of the main window, to switch the language of the interface as well as to change the

composition buttons in the side menu.

The contents of the section are as follows:

Mode main window

Scale main window

Side Menu Interface

Language Switching
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Main Window Mode
The mode is a set of the displayed and hidden interface elements of the main window.

Two modes exist in inPhoto ID Webcam: Window mode and Compact mode. You can switch the

mode in the main menu.



Chapter 2. Interface

55

In the Window mode, the main program window contains the main menu bar, the status bar and the

following buttons of the side menu: Rotate Right, Rotate Left, Processing settings. Please note

that the interface settings of the side menu not regulate displaying of the listed buttons which will be

described below in the Side Menu Interface section. Hiding these buttons is only possible by

changing Window mode to Compact mode.
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In compact mode, the main menu panel and the status bar are hidden; some buttons of the side

menu are removed.
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If you permanently use only one button on the side menu, the Capture to TWAIN button or the

Capture to File button, you can leave only one necessary button and hide the others. For this

purpose, in the File -> Options menu, deactivate displaying settings for all the buttons except for the

one you wish to leave, then switch the application main window to the compact mode. If only one of

the Capture to TWAIN and Capture to File buttons has been left in the menu, its name is

shortened to "Capture".
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However, the access to the functions of the main menu is needed when using the program this is

why the main menu is modified to the context menu in the compact mode. The context menu

completely duplicates the composition and functions of the main menu in the Window mode.

 text
Please note that the context menu is only available from the preview.
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To return the window view from the Compact mode to the Window mode, open the context menu,

select the View item and press the Window mode item as shown in the picture below.
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Main Window Scale
The scale allows you to resize of the main window.

The scale settings are in the View main menu.
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By default, the application window is shown on a scale of 100%.

The below illustrations show the view of the window on a scale of 50% and 150%.
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Side Menu Interface
The side menu is designated for more convenient and quicker access to the frequently used

functions.

In the side menu the user can display or hide a part of the buttons at his own discretion.
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All the side menu interface settings are located in the File menu > Options > General tab > User

Interface Settings section.

 The table with the setting names and respective displaying buttons is given below.

Show Capture to TWAIN button Capture to TWAIN

Show Capture to File button Capture to File

Show Capture to Clipboard button Capture to Clipboard

Show Profile button Profile

Show Close button Close

Show Update AE/AF button Update AE/AF

Show Camera Settings button Camera Settings, 
Camera Format
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At the end of the first column, you can also find the Enable Touchscreens controls setting.
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Unlike other settings of this unit, the Enable Touchscreens controls setting is not tied to a specific

button. This setting changes the side menu interface to the one that is more convenient for the usage

in touch-screen devices.
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Language Switching
You can select and set the application interface language in the File main menu > Options >

Language tab. The English, French, German and Russian languages are currently available.

For switching to the necessary language, select it from the list and close the dialogue with OK

button. Then, the application will inform you that the selected language will be applied upon the next

start-up of the application.
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Next, close and restart inPhoto ID Webcam.

text
Please note that you should to close the program and not to hide to trey. Shutdown of 
inPhoto ID Webcam are detailed in the Shutdown section.
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Interface will be displayed with the selected language during  the next session of the program.
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Shorcuts
You can get access to many inPhoto ID Webcam commands not only from the menu, but also

using shortcuts. If a shortcut corresponds to a certain menu item, then it is indicated on the title of

this item as shown in the picture below.

The full list of the shortcuts and commands related to them is provided below.

F1 Calls up the help file

F2 Updates auto focus and auto exposition of the webcam

F3 Calls up the window of the webcam properties

F4 Starts up  Capture to TWAIN

F5 Starts up  Capture to File
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F6 Starts up  Capture to Clipboard

Ctrl+E Calls up the Select Camera window

Alt+O Calls up the Options dialogue window

Alt+X Closes inPhoto ID Webcam

Alt+1 Sets up the scale of the window 10%

Alt+2 Sets up the scale of the window 25%

Alt+3 Sets up the scale of the window 33%

Alt+4 Sets up the scale of the window 50%

Alt+5 Sets up the scale of the window 75%

Alt+* Sets up the scale of the window 100%

Alt+6 Sets up the scale of the window 150%

Alt+7 Sets up the scale of the window 200%

Alt+8 Sets up the scale of the window 250%

Alt+9 Sets up the scale of the window 300%

Alt+0 Sets up the scale of the window 400%
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Shutdown
There are four ways to complete inPhoto ID Webcam operation. 

The first way: enter the File menu and choose Exit. This command always finishes work of the

application irrespective of the value of the Hide to tray instead of close setting described below.

The second way is applicable if the application is minimized to tray. In this case, call up the context

menu on the application icon and choose Close.

The behaviour of the application when closing it in the two following ways will depend on the value of

the  Hide to tray instead of close setting.
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Hide to tray instead of close replaces closing inPhoto ID Webcam by minimization to tray. The

setting influences closing of the application with the   button and its automatic closing after image

capturing if the Close after processing setting is enabled. The setting does not influence closing

the application through the File main menu > Exit. The application will always close when using Exit.

Hide to tray instead of close is located in the File main menu > Options > General tab. The

setting is enabled by default.

The third way: enter the File menu> Options > General tab and enable the Close after

processing setting. If this setting is enabled, the application will complete its work after image

capturing. Whether the application will close completely or will be minimized to tray depends on the

value of the Hide to tray instead of close setting.

text
It should be reminded that image capturing is executed by the Capture to TWAIN,

Capture to File and Capture to Clipboard commands. For more details on image

capturing, please see the Processing chapter.

The fourth way: complete the work of the application with the  button in the window title. Whether

the application will close completely or will be minimized to tray depends on the value of the Hide to

tray instead of close setting.
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Chapter 3. Camera
The current version of inPhoto ID Webcam works with any web camera supporting UVC/WDM

protocol, for example Logitech or Microsoft webcams, Videology and Lumenera ID cameras. The list

of the recommended camera models is provided on our website on the product page: 

idphotocapture.com/products/inphotoid-webcam.

The contents of the chapter are as follows:

Connection

Update AE/AF

Camera Setting

Camera Format

http://idphotocapture.com/products/inphotoid-webcam/
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Connection
When starting inPhoto ID Webcam is establishing a connection to the first webcam connected to

the PC. The Image from the connected webcam is transferred to the program preview, the webcam

control and setting are carried out from inPhoto ID Webcam.

The first few seconds after a webcam has been connected the preview image may be
blurry, dark, with the incorrect colors etc. That happens because the automatic setting of
the webcam parameters requires some time. The image usually becomes normal several
seconds later.

Webcam Selection

If several webcams are connected to the PC you can open the Select Camera dialogue and connect

the right webcam to the program. The dialogue is launched via the Camera main menu > the Select

camera item. The dialogue contains a list of all webcams connected to the PC. Select the right

webcam from the list and press the OK button.
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Upon a new start, inPhoto ID Webcam automatically connects to the webcam which has been

connected the last before closing the previous program session.
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Webcam Reconnecting

If any problems have been occurred during webcam working or connecting to the program - please

use the Camera item > Reconnect. The command executes switching on/off the webcam that

usually helps.
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Update AE/AF
Updating Webcam Autoexposure and Autofocus

The exposure and focus are automatically determined by most webcams. The mechanisms that

calculate them are named respectively: autoexposure and autofocus.

Autoexposure is an automatic camera mechanism that determines the shutter speed and
the diaphragm depending on the light conditions. 
Autofocus is an automatic camera mechanism that determines the focal length to shoot
the most sharp picture.

If failures occurs in determining focus or exposure, the mechanism of automatic setting of the

webcam parameters may be restarted. Under inPhoto ID Webcam, this mechanism is launched by

the Update AE/AF command. The Update AE/AF command is located in the Camera main menu.

Also by default, the command is placed in the side menu.
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Camera Setting
Under inPhoto ID Webcam, you can configure and control the webcam directly via its driver.

Through addressing directly to driver, the user has access to all webcam features without leaving the

inPhoto ID Webcam window.

text
The webcam settings window is the driver`s window, not the inPhoto ID Webcam window
and therefore the interface language of the window may be different from the interface
language of inPhoto ID Webcam.

The command that launch the window of the camera settings is located in the View main menu >

Camera settings. By default, the command is also added in the side menu.

text
Please remember that the set of the side menu buttons is regulated by settings located in
the File main menu > Options > the General tab > the Interface item.

Most of the modern webcam settings are identical. Let`s take a look at the webcam settings on the

example of the Logitech HD Pro Webcam C920 model.
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The Logitech HD Pro Webcam C920 settings window has three tabs Webcam Control, Advanced

Settings and Device Info.

The Webcam Control tab contains such settings as webcam rotation, zoom, focus following the

face in the frame, autofocus on-off and the microphone on-off (the microphone is built into this

model).
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On the Advanced Settings tab, you can define exposure, gain, brightness, contrast, color intensity,

white balance, anti-flicker and image orientation.

Change of settings will be immediately displayed in the preview.
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The  Device Info tab contains common information on the camera and driver as well as reference to

details on device configuring and support.
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Camera Format
The Camera Format command is located in the View main menu it is also duplicated in the side

menu.
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Camera Format opens a dialogue window that contains a list of possible resolutions for the

connected webcam.

To change resolution, please select the necessary row from the list and press the OK button.

text
If the Camera Format window is opened, the image transfer from the webcam stops and
preview freezes.

The selected resolution will be applied to both the preview and the captured image.
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Chapter 4. Preview
In the preview area, you can see image transferred by the webcam with the setting that you have set

in inPhoto ID Webcam.

The image preview is important before shooting because if you cannot see the future result then it

will be very difficult to build a correct frame and to set the required settings.

text
Hereinafter, the preview area will also be referred to as "preview". 

The change of any webcam parameter that affects image is displayed on the preview immediately.

The change of the inPhoto ID Webcam settings for frame building is also displayed on the preview

immediately. The change of the inPhoto ID Webcam settings for image correction such as

brightness, contrast, gamma etc. is not displayed on the preview. The result of image correction you

may be seen in the ID Image Processing dialogue during processing. The image processing

dialogue and the settings for image correction are described in details in the General Settings, ID

Image Processing dialogue, Image Correction, Actions sections.
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The contents of the chapter are as follows:

Auto Face Detection

Tools



Chapter 4. Preview

89

Auto Face Detection
The mechanism of the face detection performs the following: it detects the face area on image, it

calculates the area of the future processed photo on the basis of the face area and shows the

borders of the face area and the area of the future ID photo on the preview. 

text
Hereinafter, the preview area will also be referred to as "preview". 

The area of the future photo calculated on the basis of the settings selected by the user. The user

can set such parameters of the future photo as dimensions, proportions ( the form of the shot ), the

face location in the shot ( striclty at the center or closer to the shot border), zoom for area occupied

by a face in the shot (the face can take a larger or a smaller part of image). 

 To get more info about frame building, please see in the Frame Setting section.

On the preview, the face area is highlighted with a yellow frame. There will be no frame if no face is

detected or the face detection is disabled in the program settings.

The area of the future processed photo also has a frame around on the preview, but green. The

image will be cropped on the basis of this frame.
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The frame of the future photo may change color to red; it means that the distance between the frame

and the edge of the image is less then you have set in the settings. It may take place if the face is

located too close to the edge of the photo.
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If the face detection is enabled, the image on the preview will be divided into two areas: color and

black/white. The area located inside the image frame is displayed in natural colors. The area located

outside the image frame and will be cropped after processing is displayed in black and white. Such a

mechanism gives you a better view of the future processed image.

On the picture below, a fragment with a tie is highlighted; it illustrates best the difference in colors

between the frame inside and outside areas.
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The settings for the face detection are located in the File menu > Options > the Processing tab >

the Auto face detection item.

Let’s describe function of the each setting.

Enabled switches on/off the face detection, both for to the preview and for the processing. If

Enabled is off all settings related to the face detection and frame building won`t be applied to the

image. 

Show face frame on preview switches on/off the face detection only on the preview. The setting

doesn`t affect image processing.

Tracking speed sets the frame number in the frame stream received from the webcam where a

face is to be found. By default, the tracking speed is set to 6; it means that the program will search

face on every sixth frame received from the webcam. For example, if the value is 10, the tracking

speed will be lower because the search will be executed only on every tenth frame. Decreasing the

search speed reduces charge on your PC. Increasing the tracking speed may be needed if the

image changes rapidly. So, the setting helps you to choose the optimal tracking speed according to

the shooting conditions and capabilities of your PC.
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Tools
The tools for the preview are located in the Live View menu.

Let's take a look at the function of each tool.

Rotate Right/Left rotate image by 90 degrees to the right or to the left. The image rotation is

displayed on the preview and is taken into account in processing. The webcam rotation to the portrait

mode allows to increase the useful image area because the format of identification images generally

has greater high. As the result, you can get the final image in a higher resolution than when using a

usual landscape webcam orientation. This also applies to the modern HD formats. The webcams

with an option for connecting a tripod are best suited to use in portrait mode those are such models

as Logitech HD Pro Webcam c920 или Microsoft LifeCam Studio. Once you set up such webcam

on a tripod with rotating head, you can simply set the webcam in portrait mode.

Reset Rotation is used to quickly return image to original position after one or several rotations.
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The following set of tools is designed to work with exposure and lighting in the shot.

text
Composition is the harmonious placing of the various image elements according to the
author`s intention and allowing to fully deliver him thoughts and feelings to the viewer.

Grid

Cross-Hair

Exposure Control
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Grid
The grid is non-printing horizontal and vertical lines covering image. The lines help photographer to

align the basic elements of the photo vertically and horizontally. In case of portrait photography, they

usually align shoulders and head slope.

The grid 3 x3 is the most used; it consist of two vertical and two horizontal lines. It is felt that if you

look at a photo your eye is focusing its attention on the lines dividing image into thirds.

Photographers call this the " Rule of Three Thirds". Images look more interesting and harmonious if

the basic objects are placed at the borders of the thirds. For portrait photography, this rule is

applied to reveal and emphasize the face features. As usual, the eyes and the lips are typically

placed on the "attention" lines.

You can select type and color in the Set Grid dialogue. To open the dialogue, go to the Live View

menu and select Set Grid.
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Dialogue Elements:

Type is a list of the grid types. The list includes both the grids with the lines of different frequency and

just the horizontal and vertical lines.

Color shows current color of the grid lines.

Change color open a system dialogue for color selection.
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The result of the selected settings is shown in the picture below.
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Cross-Hair
Cross-Hair set the center of the image or crossing points of the grid lines. 
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You can select type and color in the Set Cross-Hair dialogue. To open the dialogue, go to the Live

View menu and select Set Cross-Hair.
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Dialogue Elements:

Type is a list of the cross-hair types. The list includes two cross-hair types that mark the center of

the frame and one cross-hair type that marks crossing points of the grid lines.

Color shows current color of the cross-hair lines.

Change color open a system dialogue for color selection.

text
It is the most convenient to select colors contrasting with image for the grid and the cross-
hair.

The result of the grid and the cross-hair applied is shown in the picture below.
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Exposure Control
Exposure control switches on/off highlighting too light and too dark areas on the preview.

text
Exposure is the amount of light hitting a photosensitive material of the camera during a
certain period of time.

text
Correct exposure is such amount of light that makes the largest number of color as bright

as possible in a photo.
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Too light image areas are highlighted in green, too dark areas are highlighted in red.

The exposure control helps photographer to choose lighting for shooting to avoid darkened or

lightened image.
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Chapter 5. Processing Settings
Processing is the key function of the application. This chapter will describe all processing functions,

settings and options in inPhoto ID Webcam.

The processing procedure can be divided into several stages. 

· Automatic face detection and framing. 

· Setting up image composition (aspect proportions, face positioning, rounded corners etc.).

· Parameters of photo volume, quality and size after processing.

· Image correction (setting up contrast, brightness, gamma etc.).

· Setting up carrying out of the processing procedure if no face has been detected on the
photo. 

· Saving processing results.

The contents of the chapter are as follows:

General Settings

Saving image

ID Image Processing dialogue

Actions

Processing Completion



Chapter 5. Processing Settings

105

General Settings
The settings regulating carrying out of the processing procedure can be found in the Options

dialogue > Processing tab.
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Let's take a closer look at it.

Image processing allows enabling or fully disabling image processing. When it is enabled, you can

select a processing parameter in the drop down below. For inPhoto ID Webcam, this parameter is

face finding. If the setting is disabled, a captured image will be saved in the specified folder or

passed via TWAIN as well as when the setting is active. In this case, the captured image will not be

processed using auto face detection and the processing settings. Processing parameters are

located in the ID Image Processing dialogue which will be described in details below in the ID

Image Processing dialogue section.

Settings from the Show processing window unit determine when the image processing dialogue

should be shown to the user during processing.
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Image processing allows enabling or fully disabling image processing. When it is enabled, you can

select a processing parameter in the drop down below. For IDPhoto Processor, this parameter is

face finding.

Show processing window setting regulates in which cases the image processing dialogue should

be shown to a user.

Show if necessary means that the dialogue will be called up only if the user's interference is

required. If the face has been found and the outer box of the frame fits completely in the image, the

processing was successful and no dialogue will be shown to the user. If the face is not found or is

found, but is too close to the image border while the outer box is not fitting in the image then the

application will call up the dialogue, so that the user is able to make corrections manually and choose

a further action. This may include saving the image with default settings or with settings modified by

the user, skipping the image or canceling the whole processing procedure.

Always means that the processing dialogue will always be shown. Also in those cases when

processing is going well. This application behaviour allows the user to control the processing

procedure. 

Newer means that the processing dialogue will not be called up. This option is applied when

complete withdrawal of human involvement in the processing procedure is required.

So what happens with the images that failed to be processed?

If no face detected on the photo, the settings in the ID Image Processing dialogue on the Frame tab

will not apply to the image. The settings of size and correction in the ID Image Processing dialogue

will apply both if a face on the image is detected and if not. The processing settings in the ID Image

Processing dialogue are described in details further in this chapter, the ID Image Processing

dialogue section.

When the face is found, but the outer box does not fit in the image, the image will be cropped after its

predifined borders.

Settings contained in the Auto face detection and Exposure control units have been described

earlier in the chapter 4 Preview in the Auto face detection and Tools sections.
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Image Saving
It is necessary to set up the saving parameters of the resulting image before starting the processing

procedure. The settings can be found in the File menu > Options > Save file tab.

Let’s describe function of the each setting.

Folder to save images indicates the path to a folder in which the program will save processed

image. Please note that the disk must have enough free space for the images, and the access to the

folder should be allowed.

Destination format - a field for selecting a format in which the processed image will be saved.

Filename prefix - is  a field for entering a set of characters which will be automatically added to the

filename of the processed image.

Flatten date - on the name of saved file, it merges year, month and day into name of one subfolder.

If the setting is switched off, the program will consider year, month and day values as subfolder

names.
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Ask before saving - if the setting is switched on, the program will further show the Save as

dialogue before saving processed image.

Separate folder for: includes the year, month and day settings described below. This settings add

the subfolders to the filename. The subfolder name is generated from the year, month and day

values current at the time of saving image.

The value of the Flatten date setting is also taken into account here. If Flatten date switched off, the

subfolders for year, month and day will be created separately.



inPhoto ID Webcam

110

If Flatten date is switched on, one subfolder will be created instead of the several subfolders. On the

name of this subfolder, the year, month and day values will be flatten.

Year adds the current year value to the name of the processed file.

Month adds the current month value to the name of the processed file.

Day adds the current day value to the name of the processed file.
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Next image contains a full name that will be assigned to the processed image when saving. This

field is not available for edition, and you can only change it using the settings located on this tab.

Reset counter resets to zero the counter of the processed images. It will be applied if the Counter

setting is activated.

Counter counts the saved images and adds the appropriate number to the file name.
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Overwrite - the setting will be applied if a file with the same name already exists in the folder into

which the processed image is to be saved. If Overwrite is switched off, the existing file with the

same name will remain unchanged and the name of the file to be saved will be changed. If

Overwrite is switched on, the file to be saved will be written instead of the file with the same name.

JPEG Quality allows defining the compression degree of the image being saved. It applies only to

the files of JPEG format.

Limit size sets the upper margin for the image size. This is measured in kilobytes. If this parameter

is selected, then JPEG Quality will be chosen automatically to fit the file size.

Set resolution allows setting resolution for JPEG images.Set resolution allows setting resolution

for JPEG images.

text
The DPI value is applicable not only for saving images into the file, but also for transferring
them via TWAIN driver.

DPI affects the quality of an image when printing it out. This parameter sets the number of ink dots

that the printer is capable of placing on your image per inch. Based on the image size in pixels and

DPI value, the size of the image to be printed is calculated in the physical units (inches, centimeters

etc.).



Chapter 5. Processing Settings

113

ID Image Processing dialogue
The image processing dialogue contains face detection, framing, adjustments settings and part of

the resulting image size settings. 

The dialogue may be called up in three ways. The first way: File menu > Processing settings. The

second way: from the side menu by the Processing settings button. 

The Processing settings button of the side menu may be hidden if the main window of the
program is switched to compact mode. To change mode of the window, open the context
menu on the preview and select View > Window Mode. For more details on the main
window modes, please see the Main Window Mode chapter.
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The third way: the dialogue is called up while the processing is progressing.

text
The Show processing window setting determines in what cases the dialogue will be
called up automatically during processing. You can find out more on the application
behaviour settings in the General Settings section.

In the first two cases, the dialogue will open for the standard test image. If you change the settings in

the dialogue for the test image, the new settings will be accepted as the default ones. If you change

the settings in the dialogue called up during processing, then the new settings will be applied only to

the current image. 

Let's call up and view the dialogue of processing for the test image.
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The most part of the space in the dialogue is allotted to the processing result preview window. To the

right, there is an original image view window. Settings are placed in the lower part of the dialogue.

In the source image preview window, two bounding boxes are applied on the photo: the internal

yellow box and the external one which may be green or red. The internal box outlines the face area.

No bounding box will be present if the face is not detected or the face search is disabled by means of

the application settings. The face bounding box can be enabled or disabled with the Face button

which is located below the source image window. The internal box can be expanded, reduced or

moved to the left, to the right, up or down. This can be done with the mouse in the source image

window or through the button toolbar below the window. All actions with the internal box are

automatically applied to the outer one.

The outer box shows the image margin after which cropping of the image will be performed. If the

distance between the face area and image margins is smaller than the distance set in the settings,

then the outer box will be red. For example, if the face is too close to the edge of the photo.

Below the image window there is a toolbar with buttons for setting the boxes. Let's list the buttons it

contains and their respective functions.

The  button increases the area of the face to be outlined together with the frame box;

correspondingly, the   button decreases it.

The     arrow buttons move the outlined face area together with the frame box to the

left, to the right, up and down.

The  button enables and disables outlining the face area.

The  button enables and disables outlining the centre of image.

Then, we'll view the dialogue for the image being processed. Please note that the program will call up

this dialogue during processing, if such behavior is set in the Show processing window setting. For

more details on Show processing window setting, see General Settings section.
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In the dialogue for the image under processing, unlike the test image dialogue, the OK and Cancel

buttons are replaced by the buttons for saving image, canceling processing and canceling

processing followed by closing of the program. Please refer to the Actions chapter for more details.

The contents of the chapter are as follows:

Processed Image Size

Frame Setting

Image Correction

Actions
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Processed Image Size
The information on image dimensions is contained in the Source Image Size and Result Image

Size sections.

The Source Image Size section shows the size of the source image in pixels.

The Result Image Size section shows the size of the resulting image with the current settings (also

in pixels). The size value will change depending on the change in settings. Resizing is enabled

means that the upper margin for the image size is set. Resizing is disabled means that there are

no restrictions on the maximum size of the resulting image. Click the Set button to set or remove

limits and to set the compression parameters. After that, the Resizing Options dialogue will be

called up. 
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To set or remove the upper margin for the image size, use the Set maximum size for resulting

image setting.

The second setting in this section, that is Allow image enlarge, allows enlarging the image to the

specified dimensions if the source image is smaller. In other words, if this setting is disabled, only the

images with bigger original dimensions are scaled to the specified dimensions. If the image

dimensions are originally smaller than the specified ones, the image height and width will remain

unchanged. When the setting is enabled, all the images are scaled to the specified dimensions,

regardless of whether they have initially been bigger or smaller. Please keep in mind that the quality

of the enlarged images may worsen.

The dimensions of the resulting images are set in the Width and Height fields below in the dialogue.
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Frame Setting
The composition settings and size settings are contained in the Frame unit.
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Let's look at each setting in more detail.

Apply Crop Frame enables and disables face search and further image framing. When this setting

is being disabled, the boxes from the source image window will disappear, and the image will be

displayed in its original form in the result preview window.

The processing procedure started with the Apply Crop Frame setting disabled will apply to the

image all the settings except the ones in the Frame section. It can be seen that when no cropping

after the box is set, all the settings in the section become disabled. 
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Zoom is a ratio of face area to the area of the future frame. The value of 40 is selected in the default

settings which means that the face area accounts for 40% of the area of the whole frame. Provided

the value is increased to 100, the face area will occupy the whole frame. Let's show it with an

example. First, to make the frame well-balanced, let's match the centres of the face area and the

frame area by setting the  Position vert. value to 50 and the hor. value to 50. Then we'll set zoom to

100%.
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Position: moves the frame cropping box relative to the detected face and so changes place of the

face in the image. For instance, such need may arise if it is necessary to move the image of a

person and add a company logo on the photo. In such a case, you simply need to move the frame

cropping in the required direction. Offset values are given in per cents.
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Size: this setting allows specifying the ratio of the frame sides. E. g., with width to height ratio as 4:

4, the frame will have a form of a square. To specify the sides ratio, just indicate the required frame

dimensions.
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Frame effect is the list of effects that can be applied to the image frame. There is only one

Rounded corners effect in the list at present. Click the Settings button placed to the right of the list

to change the Rounded corners settings. In the shown dialogue window, you may set the rounding

radius and background colour for the corners.

Reset is the last button in this section which makes it possible to cancel changes of all the settings

and return them to default state.
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Image Correction
All settings for image correction are placed within the Correction tab.

Here you can set such parameters of photo as brightness, contrast, gamma, sharpness, and

greyscale. All changes of the settings will be displayed in the preview.

Brightness — this parameter indicates how much do image pixel colours differ from the black  colour. E. g. the

brightness of the photo taken in sunny weather will be significant and visa versa that of the photo taken in the

evening or at night will be low. Brightness is set in the range from - 100 to 100.

Contrast is one of the main image parameters, it regulates pixel brightness. When increasing the contrast, the

light areas (pixels) of the image become lighter, while the dark  ones become darker. And visa versa, when

reducing contrast, dark  pixels become lighter, while the light ones become darker and thereby the number of

pixels move to midtones. Contrast is set in the range from - 100 to 100.
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Gamma — this image parameter allows changing colour intensity of dark  pixels to a greater extent than that of

light ones. In other words, it is possible to increase contrast, distinctness of the dark  areas of the image, while

not mak ing light details of the photo too contrast or bright.

Sharpness is also one of the main image characteristics; it indicates the quality of reproduction of large

fragments on the photo. Increasing sharpness is one of the common ways of improving image quality. Actually,

increasing of the sharpness decreases the width of the borders between image areas with different brightness.

The narrower the border, the sharper looks the photography. This is reached by lightening lighter pixels on one

side of the border and by darkening the darker ones on the other side.

Grayscale — this option allows mak ing black-and-white photo from the colour one. In the Grayscale mode, all

the colours are cancelled for the image and only information on pixel brightness is saved. Furthermore, all the

colours on the photo are transferred to the grayscale.

The Reset button makes it possible to cancel changes of all the settings and return them to default

state.
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Actions
If the processing procedure runs without calling up ID Image Processing dialogue, the processing

will be completed automatically. In such a case, the user does not need to take any actions.

If during processing, the dialogue will be called up, the user needs to choose one of the possible

actions after the process is completed. Possible actions are represented by the Save, Back and

Close buttons.
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Save saves the photo with the settings set in the dialogue.

Back interrupts processing, closes the face image processing dialogue and takes the user back to

the application main window. The Back button is used for cancelling the current image processing

and starting making a new shot.

The Close command interrupts processing and closing the program.

The Esc key on the keyboard performs as the Back command. This option closes the ID Image

Processing dialogue and interrupts processing if it has been started. 

For stopping the processing by means of the Esc key, the application will ask for the confirmation.



Chapter 5. Processing Settings

129

Separately from the actions buttons, there is the Set as default button in the dialogue. Set as

default saves settings in the dialogue as settings by default. If you would like further images to be

processed with the settings you have applied in this dialogue, press Сохранить по before pressing

Save, Back or Close. 

Pressing Set as default only affects saving settings and does not affect image processing process.

After pressing the Set as default button, the processing dialogue will remain open and the

application will wait from the user for one of the actions of the Save, Back, Close buttons. 
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Processing Completion
After completing the processing procedure, the application can be closed or minimized to tray. Such

behaviour is regulated with the Close after processing and Hide to tray instead of close settings.

The settings are located on the File main menu > Options > Explorer tab.

If the Close after processing option is enabled, inPhoto ID Webcam completes the work after

processing. Whether the application to be closed or to be minimized to tray depends on the Hide to

tray instead of close setting.

The active Hide to tray instead of close setting changes closing inPhoto ID Webcam to

minimization to tray.
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Chapter 6. Processing
In the previous chapters, we have described all functions and settings for image processing. Now, it

is time to run the process and take a look at how it progresses.

There are three types of image processing in the application: Capture to TWAIN, Capture to File

and Capture to Clipboard. In all three cases, the capturing process is identical and it is only saving

the processed image that differs. Capture to TWAIN sends the processed image to the application

or to a device through the TWAIN driver. The results transfer through the TWAIN driver will be

described below with the XnView image viewer taken as an example. Capture to File saves an

image to the specified folder on the drive. Capture to Clipboard saves an image to the clipboard. In

this case, it is convenient to paste the image into a document or another application without interim

saving.

text
You can interrupt the processing process by pressing the Esc key on the keyboard.

Let's take a closer look at each capturing method.

Capture to TWAIN

Capture to File

Capture to Clipboard
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Capture to TWAIN

Contents of the section:

About TWAIN

Capture to TWAIN
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About TWAIN
TWAIN is the software protocol that makes it possible to directly transfer images from image-

capturing devices, like scanners and digital cameras, to applications.

Without TWAIN, you would first need to save the image to a disc and only after that the user

application will be able to open it.

Thanks to TWAIN, application software and image-capturing devices can understand each other and

interact.

Image-capturing devices work via TWAIN data source usually called TWAIN driver. Not only a real

device, like scanner and digital camera, but a software as well can serve as a data source.

The following IDPhotoCapture products support the work as data sources:

· inPhoto ID Webcam

· inPhoto ID PS

· inPhoto ID SLR

· IDPhoto Processor

· inPhoto Capture PS

· inPhoto Capture SLR

TWAIN protocol comes with a data transfer standard and API interface. TWAIN drivers are

applications for managing image-capturing devices written on the basis of the TWAIN interface.

Normally, TWAIN drivers have a graphical interface and function as a data source control panel.

TWAIN drivers also allow configuring image settings, such as colour balance, size, gamma range,

etc. before the image is received by the application. Sets of settings in TWAIN drivers differ

depending on a data source device.

Image transfer with TWAIN involves user application, supporting TWAIN protocol to which the image

will be transferred and TWAIN driver which serves as an image source. Most applications for image

handling are currently supporting TWAIN, however please refer to the application supplier or to the

documents to find out about such a possibility.

Only application can initiate an image transfer, so it is from this that the TWAIN call have to start.

http://idphotocapture.com/products/inphotoid-webcam/
http://idphotocapture.com/products/inphotoid-ps/
http://idphotocapture.com/products/inphotoid-slr/
http://idphotocapture.com/products/idphotoprocessor/
http://idphotocapture.com/products/inphotocapture-ps/
http://idphotocapture.com/products/inphotocapture-slr/
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Various applications have their own commands for receiving files from a data source. Normally,

these commands are found in the File menu and labelled as Acquire or Import. In some

applications, you need to previously indicate a data source. For this purpose, a TWAIN source

command is used which is also normally found in the File menu.

Diagram of image transfer via TWAIN.

1. A user selects and starts the TWAIN driver from the application to which the image is to be
transferred.

2. After a TWAIN driver call, the application enters the standby mode and waits for response of
the driver on the image readiness for being transferred. The application may be locked in
standby mode. In reality, the behaviour of each application may differ and depends on the
features included into it by developers.

3. While the application is waiting, the driver becomes a main controlling unit. The user
manages a data acquisition device and captures an image.

4. After the image is captured, the driver transfers it to the waiting application.

5. After the transfer process is finished, the application may demand to close the driver. Further
transfer via TWAIN is impossible with closed driver. For re-transferring the image, you need
to start the procedure from the very beginning, calling out the driver from the application
again.
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Capture to TWAIN
The Capture to TWAIN command executes snapshot, its processing and transfers them to external

application which connected to inPhoto ID Webcam via TWAIN protocol. As an application in which

processed photo will be transferred we use image viewer XnView.

It should be reminded that inPhoto ID Webcam is an image source in TWAIN connection. 

So, turn on the webcam and start inPhoto ID Webcam. 

Unlike the rest of the program functions, the Capture to TWAIN button and the menu item are

disabled. This is right. The possibility to transfer images via TWAIN driver will arise when inPhoto ID

Webcam receives a request from the third-party application for opening TWAIN connection. By this

moment, the Capture to TWAIN elements will be disabled.
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Let's open TWAIN connection and enable Capture to TWAIN function. For this purpose, start

XnView, enter File main menu and select Select TWAIN source.

In the appeared Select Source dialogue, select inPhoto ID Webcam from the source list.
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Then, in the same File menu, select Acquire.

If by that moment, inPhoto ID Webcam has been closed or minimized to a tray, now it will be

started.
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So, we connected XnView to inPhoto ID Webcam via TWAIN protocol. Now we move to inPhoto

ID Webcam - Capture to TWAIN menu item and button now have been enabled.

Next, we start Capture to TWAIN.

Process to TWAIN may be started from Capture main menu > Capture to TWAIN or from the side

menu by pressing Capture to TWAIN button.

The Capture to TWAIN button from the side menu may be hidden if the application
interface is set up in such a way. To make the button visible, enter File menu > Options>
General tab and set up Show Capture to TWAIN button. For more details on setting of
the side menu interface, see chapter Side Menu Interface.
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Further course of processing depends on the settings set by the user. Please note that the key

processing settings are located in the File main menu > Options > Processing tab.
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If the Show processing window option is set the Always value, then the ID Image Processing

dialogue will be called up for image being processed.

If the dialogue opening setting is set to the Show if necessary value, the dialogue will be opened only

if a user's participation is needed for processing the image. The dialogue will not be opened for

successfully processed photos.

If the Never option is selected, processing will be carried out without opening the ID Image

Processing dialogue. Images that cannot be processed automatically will remain unchanged. 

You can read more details on processing settings and the ID Image Processing dialogue in the

General Settings, ID Image Processing dialogue, and Actions sections.
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After completing the processing procedure, we return to XnView and look at the result of the

command Capture to TWAIN. As can be seen on the picture, the image are successfully captured,

processed and transferred to XnView.

The process of connecting to other applications via TWAIN driver is similar to that, exemplified by

XnView. It is noteworthy that applications may close the channel for TWAIN driver after image

transfer is completed. Because of the channel closure, the TWAIN connection will be lost and the

Capture to TWAIN button will be disabled. To enable it, you need to repeat the process of selecting

a scanner.

Please note that inPhoto ID Webcam is set by default as to be minimized to tray after processing

completion. More details on settings regulating processing completion may be found in the 

Processing Completion section.
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Capture to File
The Process to File command executes snapshot, its processing and saving to the specified place

on the drive.

The command can be started from the Camera main menu > Capture to File or from the side

menu by pressing the Capture to File.

text
The Capture to File button from the side menu may be hidden if the application interface
is set up in such a way. To make the button visible, please enter the File menu > Options
> General tab and set the Show Capture to File button setting.

So, let's run the Capture to File command and take a look at how it works.
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Further course of processing depends on the settings set by the user. Please note that the key

processing settings are located in the File main menu > Options > Processing tab.
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If Always is selected in the settings, then the ID Image Processing dialogue will be called up for

image being processed.

If the dialogue opening setting is set to the Show if necessary value, the dialogue will be opened only

if a user's participation is needed for processing the images. This value is set by default. The

dialogue will not be opened for successfully processed photos.

If the Never option is selected, processing will be carried out without opening the ID Image

Processing dialogue. Image that cannot be processed automatically will remain unchanged. 

You can read more details on processing settings and the ID Image Processing dialogue in the

General Settings, ID Image Processing dialogue, and Actions sections.
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Then, to see the processed images we enter the folder indicated in saving settings. Please note that

the saving settings are located in the File menu > Options > Save file tab.
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The result looks like this. You can see in the picture that photo have been successfully captured,

processed and saved to the specified folder.

By default, inPhoto ID Webcam is set as to be minimized to tray after processing completion. More

details on settings regulating processing completion may be found in the Processing Completion

section.
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Capture to Clipboard
The Process to Clipboard command executes snapshot, its processing and saving to the

clipboard.

The command can be started from the Camera main menu > Capture to Clipboard or from the

side menu by pressing the Capture to Clipboard.

By default, the application interface is set in such a way that the Capture to Clipboard
button is hidden on the side menu. To make the button visible, please enter the File menu
> Options > General tab and set the Show Capture to Clipboard button setting.

So, let's run the Capture to Clipboard command and take a look at how it works.
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Further course of processing depends on the settings set by the user. Please note that the key

processing settings are located in the File main menu > Options > Processing tab.
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By default, the program opens the ID Image Processing dialogue during processing only if a user's

participation is needed for processing the image. The dialogue will not be opened for the successfully

processed photos.

You can read more details on processing settings and the ID Image Processing dialogue in the

General Settings, ID Image Processing dialogue, and Actions sections.
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Upon processing completion, the image is placed into the clipboard. To see the result, let's paste the

processed image from the clipboard into Microsoft Word, for example. 

For this purpose, please open Microsoft Word and press Paste on the Home tab of the main menu.

After that, the processed image will be pasted into the document. The result is shown in the picture

below.

Please note that inPhoto ID Webcam is set by default as to be minimized to tray after processing

completion. More details on settings regulating processing completion may be found in the 

Processing Completion section.
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Chapter 7. Voice Control
inPhoto ID Webcam provides the following voice features: process control using voice commands

and voice message indication before shooting.

This features are described in details in the following sections:

Voice Control

Voice Informant
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Voice Control
The voice features allow user to manage image shooting and processing remotely. In other words,

after frame setting you can freely move giving voice commands and inPhoto ID Webcam will

recognize and execute them.

text
To use voice features, connect a microphone to your PC.

Please note that the voice features are only available if the language your system locale is English.

The Microsoft Windows system doesn`t support speech recognition for other languages. If your

system locale is not English, you will see the follow message "Your operating system doesn`t

support voice recognition" opposite to the Enable voice control setting and the setting itself will

not be activated.

At the time of writing of the User Guide, English is included in the Windows Enterprise and

Windows Ultimate packages. How to identify the language of your system locale and how to

change, it you can find it out on the Microsoft website by clicking on the following links: 

http://windows.microsoft.com/en-us/windows/change-system-locale#1TC=windows-7 - for

http://windows.microsoft.com/en-us/windows/change-system-locale#1TC=windows-7
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Windows 7 and http://windows.microsoft.com/en-us/windows/change-system-

locale#1TC=windows-vista - for Windows Vista.

Then, we are describing how to use voice features step-by-step.

Step 1. Switch on the Enable voice control setting. After that, all fields of the tab are activated. 

http://windows.microsoft.com/en-us/windows/change-system-locale#1TC=windows-vista
http://windows.microsoft.com/en-us/windows/change-system-locale#1TC=windows-vista
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Step 2. The tab then contains the possible commands. There are a list of command launching

words against each command.

The Control switch command helps to improve recognition of other commands. So, if a control

switch is on, the words specified for other commands will be recognized by the program only after

the control switch word sounding. If you say the launched word and don`t say the control switch

before it in everyday speech, the word will not be considered by the program as the voice command.

If you are not convenient to use the control word you can select the None value. In this case, you just

have to say one word to launch the corresponding command.

More details on the Capture to TWAIN and Capture to File commands you may be found out in the

Processing chapter, the Capture to TWAIN and the Capture to File sections.

The Update AE/AF command is described in the Camera chapter, the Update AE/AF section.

Then, select a launching word for each command that you intend to use. For this reason, say the

launching word and evaluate how it is convenient to use.
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Step 3. At this step, we are describing how to configure and test your microphone.

The Configure voice recognition link located at the bottom of the tab opens the Speech

Properties dialogue.



Chapter 7. Voice Control

159

You can select the desired microphone in the dialogue (if several devices are connected) to check

that it works properly, to listen to your message recorded through the selected device, to change the

microphone settings. 

So, change the microphone settings if required, make sure the microphone transfers your voice

messages to the operating system and then proceed to the next step. 
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Step 4. To be sure the voice command has been recognized and implemented, it is convenient to

use the voice commands together with the voice informant. The voice informant displays a

countdown panel for shooting and transfers the "Attention! Look in to the camera. Shooting!"

voice message to the playback device. Thus, if the voice informant is counting down, it means your

voice command is implementing.

text

The informant is launched only just before shooting. It will therefore be active during
implementation of the Capture to TWAIN and Capture to File commands. Please note
that the informant will not be applied to the Update AE/AF command.

More details on the voice informant may be found in the Voice Informant section. At this stage, you

are recommended to read about it and switch it on. However, switching on isn`t a mandatory action

for use of the voice commands. 
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Step 5. When your microphone is ready, the launching words are selected, the voice informant is on,

say your voice command and check out the result of its implementation.

So, say one of the launching words loud and clear, for example, Save. If the voice informant is on,

you will hear a message and see a countdown timer in the program window; after that, the image will

be captured and then processing will be launched. The program can open the dialogue of image

processing during processing. That cases the dialogue will be called up and that actions you can

select therein are described in more details in the General Settings, ID Image Processing

dialogue and Actions sections.

text
If your voice command has not been recognized, use an alternative launching word or
correct the microphone settings.
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Step 6.  Let`s check the command execution result. We have said the Save word that launched the

Capture to File command, therefore the image should be captured, processed and saved in the

specified folder on the disk.

text

The folder into which the program will save processed images you may be entered in the
main menu: Options > General > Save file > Folder to save images.

The command has been successfully executed as shown in the picture below: the processed image

is located in the folder.
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Voice Informant
The function of the voice informant is to transfer a message to the playback device before shooting.

If the informant is on, the user will hear the "Attention! Look in to the camera. Shooting!" voice

message before shooting. In parallel with the message sounding a counting down timer is displayed

in the preview.

text
To hear the message make be sure the sound device of your PC (speakers, a headset
etc.) is on.
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The informant settings are located in the File main menu > Options > the Informant tab.
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The Enable Voice Informant setting switches on/off a voice message indication before shooting.

The Configure text to speech link launches a dialogue to set the speech. The dialogue is open on

the Text to Speech tab. On the tab, you can select and listen to the voice that will sound the

message, set the voice speed, define the audio output device.
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To see how does the voice informant work, switch on the Enable Voice Informant setting and

launch processing using any of three ways: Capture to TWAIN, Capture to File, Capture to

Clipboard. After that, a timer will be displayed on the preview. In parallel with counting down of the

timer, the voice message will sound. Then image will be captured.
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Chapter 8. External Tools
There is a possibility for connecting external tools to the inPhoto ID Webcam. Such feature allows to

automatically execute additional actions with the processed images. For example, image can be

send via e-mail or open in the graphical editor right after processing without any interim actions by

the user.

Further in this chapter, we will describe general algorithm of interaction between external tools and 

inPhoto ID Webcam and we will demonstrate how to send processed images via email, open them

in a graphic editor and name images correspondingly to the content of xls file.

The contents of the chapter are as follows:

Connection

Editing and Deleting

Example with the SmtpSend Email Client

Example with the Paint.net graphic editor 

Example with RenameFileByXL
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Connection
All actions with external tools are to be done via the menu File > Options > the External tools tab.
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To the fields to become active - select the required tool from the External tools (Actions): list or

press the Add button, if the list is empty.
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The External tools (Actions): box is the list of connected tools.

In the Title field, you can enter any convenient designation for the action that is performed by the tool.

The designation that you enter will not affect inPhoto ID Webcam it is necessary to display the tool

in the list of connected tools External tools (Actions):.

In the Target box, you need to indicate the path to the tool file or package file. Here you can state

files with the exe, com, bat, cmd extensions.

After completing the Title and Target fields, the tool will appear in the External tools (Actions): list:
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In the Start in field, there should be indicated the path to the folder from which inPhoto ID Webcam

will start searching for the files required to work with external tool. 

The Start in field is used for not entering long paths to files, but, once having indicated the work

folder, to use file names only. Such an approach allows to make information in the form fields more

indicative and to avoid mistakes. 

For example, if you prefer to enter in the Target field a file name only and do not wish to enter full

path to an application file, please state in the Start in field the folder containing the application file.

After that, you can enter all the files in this folder without paths. 

If you prefer not entering paths to auxiliary files of an external application that (the files) will be entered

into the argument string, you can state as a work folder the folder containing the files and then use

only files' names in the argument string. We will make like that in the example with the 

RenameFileByXL tool.

Example without stating a work folder:
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Example with stating a work folder:
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The Arguments field contains the command string arguments required for applying to an external

tool. Each tool has its own set of arguments. 

By default, the field contains the ImageList variable. When an external tool is addressed, the variable

gets the value of the full name of the processed image file. 

You can use the ImageList variable in the argument string or change it with the name of a specific

file or group of files. In this case, the name of file or files is to be entered fully and in quotes. Use a

space between names as a separator.

Example: "d:\portrait1.jpg" or "d:\portrait1.jpg" "d:\portrait2.jpg" "d:\portrait3.jpg".
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Execute after processing parameter enables and disables start up of an external tool after

completing image processing. Near the tool for which you active the parameter you will see the text

[post-processing].

Execute after processing setting can be set only for one tool at a time. If you assign Execute after

processing first for one tool and then for another one, then at the moment of setting the parameter

for the second tool, it will be automatically disabled for the first one.
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Add and Delete serve for adding and deleting external tools respectively.
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Editing and Deleting
As connections, editing and deleting of external tools are carried out through the File menu >

Options > External tools tab.
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To change the parameters of external tool connection, select it in the External tools list, change

parameter values and close the dialogue with OK.
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To delete the tool, select it from the External tools list, press Delete and close the dialogue with

OK.
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Example with the SmtpSend Email Client
SmtpSend is a command-line tool for sending emails. SmtpSend allows sending emails with one or

several attachments to one or several addressees and to add addresses to copy or Bcc. The tool

uses the SMTP-protocol and supports the encryption function (SSL).

SmtpSend is a product of the IDPhotoCapture Company and is a part of the inPhoto ID Webcam

installation package. After installation of inPhoto ID Webcam has been completed, the

SmtpSend.exe executive file will be placed in the inPhoto ID Webcam folder. SmtpSend may be

used not only in combination with inPhoto ID Webcam, but as an independent command line driven

program as well.

In the example provided below, we are going to connect the SmtpSend postal tool to inPhoto ID

Webcam, and then make and process an image. After that, an email with the processed image will

be automatically sent to the given address.

The email will be sent from the outlook.com postal service to gmail.com.

Please pay attention that for sending emails automatically, you have to activate in your
postal service the setting allowing it. In general, this feature is disabled by default. 

Please refer to the documents attached to your postal service or its support service to find
out how to permit automatic actions.

By the moment of creature of this manual, you must confirm your account to allow

automatic email transferring in outlook.com. For this purpose, in your account, enter the

menu Settings -> Options -> Email forwarding -> Verify your account and pass the

account validation procedure.

Contents of the example:

Creature of Configuration File

Connection of SmtpSend to inPhoto ID Webcam

Processing with Automatic Email Sending
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Creature of Configuration File
We will need a configuration file to address SmtpSend. The configuration file will contain server data,

port number, sender’s email, receiver’s email, subject, and text body of the letter.

By default, SmtpSend considers default.conf as a configuration file name, and the folder containing

SmtpSend.exe as its folder. 

You can name and place the configuration file at your discretion. You may need several configuration

files with different data set to send your emails.

In our example, we use values by default, but we will also provide you with an example of an

argument string with different name and configuration file folder.

Ok, let us create the default.conf file in the inPhoto ID Webcam folder where the SmtpSend.exe

file is located.
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Data in default.conf will be described under the JSON format. Please pay attention the JSON

format does not support commenting.

Let us take a look at all possible keys that may be indicated as settings:

host: - host name or server IP-address

Example: host: "smtp-mail.outlook.com",

port: - port number/ To send emails without encryption, they use port 25, and port 587

or 465 to send emails with encryption. The port 25 is set by default.

Example: port: 587,

enableSSL:  - encryption support. true means the encryption is active, false means

the encryption is disabled. The by default value is false.

Example:  enableSSL: true,

timeout: - server standby time. The value is set in milliseconds. The by default value

is 100000 (100 seconds).

Example: timeout: 30000,

username:  - your email  

Example: username: "send_id_photo@outlook.com",

password: - your password

Example: password: "inphoto2016",

from: - sender's email

Example: from: "send_id_photo@outlook.com",

to: - addressees’ emails list. Use a comma as a separator.

Example: to: "get_id_photo@gmail.com", or to: "a@gmail.com, b@gmail.com,

c@gmail.com",

cc: - a copy; it contains addresses to which the email will be also sent. Use a comma

as a separator in the address list. The addresses added to cc: will be visible for all

conversation participants. Optionally.

Example: cc: "d@gmail.com, f@gmail.com",
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bcc: - a blind copy; it contains addresses to which the email will be also sent, but in

contrast to cc: the addresses in a blind copy are not visible for other conversation

participants. Use a comma as a separator in the address list. Optionally.

Example: bcc: "g@gmail.com, h@gmail.com",

subject: - email subject

Example: subject: "Your ID Photo",

body: - email content

Example: body: "We are happy to deliver your photos."

Our configuration file will have the following appearance:



Chapter 8. External Tools

183

Connection of SmtpSend to inPhoto ID Webcam
Start inPhoto ID Webcam.

Enter the menu File > Options > the External tools tab.
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Press the Add button. After that, the form fields will become active.

Please remember that the fields for connection of external tools are described in the
beginning of this chapter, the Connection section. 
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In the Title field, you can enter any name that is convenient for you to designate the tool being

connected.

In the Target field, please enter the path to the executive file SmtpSend.exe.

After completing the Title and Target fields, SmtpSend will appear in the External tools (Actions):

list.
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The Start in field is to be left empty.

In the Arguments field, please enter the following arguments for the command string.

/config - path to the configuration file. By default, it contains the

path to the file default.conf located in the same folder as

SmtpSend.exe. If the path to your configuration file is the same

as the one by default, you may not indicate this parameter in the

arguments string.

If the path to your configuration file is not the same as the one by

default, please indicate it as shown in the example.

Example: /config="D:\Mail Configs\Passport Photos.conf"

/attach - path to one file or group of the files to be attached to

the letter. 

If you wish to attach a file with processed image to the letter, it's

most practical to use the $(ImageList) variable. This variable is

located by default in the Arguments field; after processing, the

full name of the image file will be appointed to it.

Example: /attach=$(ImageList)

You may also appoint the path to one file or group of the files

directly to the /attach parameter.

Example: /attach="D:\ID Photos\ID_0101.jpg, D:\ID

Photos\Info.txt"

An example of the argument string with a by default value

for /config and with use of the $(ImageList) variable

for /attach:

/attach=$(ImageList)

An example of the argument string with indication of the

configuration file and group of files to be attached.
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/config="D:\Mail Configs\Passport Photos.conf" /attach="D:\ID

Photos\ID_0101.jpg, D:\ID Photos\Info.txt"
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Please activate the Run automatically after file processing setting. After that, you will see near the

SmtpSend name the text [post-processing], that means the tool will be run automatically after

processing.

Please pay attention to that if the Run automatically after file processing setting is disabled, the

tool will not be run.
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Then press the OK button to save the connecting settings.  

Done! The tool is connected.
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Processing with Automatic Email Sending
After completing all the additional actions, let's run processing and check how does SmtpSend work.

Run shooting and processing any way you wish, for example, via Capture to File.
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Further behaviour of inPhoto ID Webcam depends on the processing process settings. It should be

reminded that they are located in the File menu > Options > Processing tab.

Thus, if the Show processing window setting is set to Always, the ID Image Processing dialogue

will be always called up for photo being processed.

Upon the Show if necessary value set, the dialogue will be called up only for photos whose

processing requires a user's participation.

If the Never value is chosen, the dialogue will not be called up.

More details on the processing setting may be found in the General Settings  section.
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After the image has been processed, inPhoto ID Webcam will run SmtpSend. While an external

tool is working, inPhoto ID Webcam displays the work completing waiting window for the external

tool. The tool window for SmtpSend will also be open. The both windows will close after completing

the work, i.e. in this case, will send an email. 
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Let's check our incoming mail box after closure of the window. 

So, in the picture below, we can see that the email has been delivered and contains an attachment

with the processed image. The sender's address, subject and content of the email are the same as

we enter into the configuration file.
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Addition

If your postal service does not allow automatic sending of emails, so, when you run SmtpSend, you

will see an error in the waiting window; in this case, the email will not be sent.

If such error occurs, you must allow automatic actions in the postal service before using SmtpSend.

By the moment of creature of this manual, you must confirm your account to allow
automatic email transferring in outlook.com. For this purpose, in your account, enter the
menu Settings -> Options -> Email forwarding -> Verify your account and pass the
account validation procedure.
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Example with the Paint.net graphic editor
The connection inPhoto ID Webcam with graphics editor is useful when you need to additionally edit

photos after processing.

In this example, we are going to connect Paint.net to inPhoto ID Webcam, then we will make and

process an image, then inPhoto ID Webcam will automatically run Paint.net, that will open the

image received from inPhoto ID Webcam.  

Contents of the section:

Connection of Paint.net to inPhoto ID Webcam

Passing an Image to Paint.net
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Connection of Paint.net to inPhoto ID Webcam
Start inPhoto ID Webcam.

Enter the menu File > Options > the External tools tab.
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Press the Add button. After that, the form fields will become active.

Please remember that the fields for connection of external tools are described in the
beginning of this chapter, the Connection section. 
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In the Title field, you can enter any convenient designation for the action that is performed by the tool.

In the Target field, please enter the path to the executive file PaintDotNet.exe.

text
Your path to PaintDotNet.exe may differ from the one shown in the example.

After completing the Title and Target fields, Paint.net will appear in the External tools (Actions)

list.
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You have no need of auxiliary files to pass processed files to Paint.net, this is why it is not

mandatory to fill in the Start in field.

The Arguments field is also to be left unchanged. By default, this field contains the ImageList

variable that will be appointed, after processing, with the full name of the processed file.
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Then activate the Run automatically after processing setting. After that, you will see near the

Paint.net name the text [post-processing], that means the tool will be run automatically after

processing.

Please note that if this setting is deactivated, Paint.net will not be started.

The Run automatically after processing setting may be made at once only for one tool.
For example, if the setting is already made for one tool, it will be automatically disabled
when you activate it for another one. 

To save connection settings made, press the OK button. 

Done! Paint.net is connected to inPhoto ID Webcam.
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Passing an Image to Paint.net
In the previous part, we have connected Paint.net, now let us see how it works.

Run image shooting and processing any way you wish, for example, via Capture to File.
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Further behaviour of inPhoto ID Webcam depends on the processing process settings. It should be

reminded that they are located in the File menu > Options > Processing tab.

Thus, if the Show processing window setting is set to Always, the ID Image Processing dialogue

will be always called up for photo being processed.

Upon the Show if necessary value set, the dialogue will be called up only for photos whose

processing requires a user's participation.

If the Never value is chosen, the dialogue will not be called up.

More details on the processing setting may be found in the General Settings section.
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After the image has been processed, inPhoto ID Webcam will run Paint.net. In addition, when an

external tool is being started, inPhoto ID Webcam  displays the work completing waiting window for

the external tool. The waiting window will close automatically after the external tool finishes

interacting with inPhoto ID Webcam. In this case, that means after the path to the image file is

passed to Paint.net. 
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As the result of the external tool work, we have got a processed image that is open in a graphic editor

without any additional actions from our part.

Then, we may continue editing the image in Paint.net. After completion of the editing, we will press

in Paint.net the Save button and the photo with all the modifications made in the editor will be placed

into the folder we have indicated for saving images in inPhoto ID Webcam.
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Example with RenameFileByXL
RenameFileByXL is a tool that renames a processed image file on the ground of the data from the

xls file.

RenameFileByXL is developed to help photographers in their work in education entities for children

and young people. 

The work with the tool is performed as follows:

Stage 1. The photographer is provided with an xls file containing a table with information on the

students: names, group numbers, phone numbers... The table must contain an ID for every person

to be photographed, it will further become the name of the file.

Stage 2. The photographer uses inPhoto ID Webcam to make and process an image. After that,

RenameFileByXL will automatically run. Then, the photographer asks every photographed student

his/her name and enter it in the search field of RenameFileByXL. The tool uses the name to find the

student ID and appoints it to the image.

Stage 3. The photographer gets an archive of numbered photos where he can quickly find, when

entering the respective name, all the required information on the photographed student. 

RenameFileByXL is a product of the IDPhotoCapture Company. You may contact our
support service to get additional information on the tool and terms and conditions of its
obtaining and use. Please see the Contact Technical Support Service section for the
support service contact details.

In the example here below, we are going to connect RenameFileByXL to inPhoto ID Webcam, then

we will make and process an image, then RenameFileByXL will be automatically run and we will

select, using the manual search, a cell in the xls file the value of which will become the image file

name.

Our xls file contains a table with records about students. To rename the image file, we will choose

values from the first column S/N - a student's number. The search will be performed using a

student's second name - the SURNAME column. 
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The table in the xls file looks like this:

Contents of the example:

Connection of RenameFileByXL to inPhoto ID Webcam

Shooting, Processing and Saving of Image

Renaming a File
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Connection of RenameFileByXL to inPhoto ID Webcam
Start inPhoto ID Webcam.

Enter the menu File > Options > the External tools tab.
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Press the Add button. After that, the form fields will become active.

Please remember that the fields for connection of external tools are described in the
beginning of this chapter, the Connection section. 
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In the Title field, you can enter any name that is convenient for you to designate the tool being

connected.

In the Target field, please enter the path to the executive file RenameFileByXL.exe.

After completing the Title and Target fields, RenameFileByXL will appear in the External tools

(Actions): list.
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In the Start in field, please indicate the path to the folder containing the xls file.

In the Arguments field, please enter the following arguments for the command string.

/excelFile - path to the xls file. Mandatory. 

If you have indicated, in the Start in field, the path to a folder

where inPhoto ID Webcam must search for axillary files, there

is no need to assign to /excelFile the full path to the xls file, it is

enough to only state the name.

Example: /excelFile="15BT81544827.xls"

If the Start in field not filled in, you must appoint to

the /excelFile parameter the full path to the xls file.

Example: /excelFile="C:\Program Files\ReFileXLS\XLS

files\15BT81544827.xls"

/imageFile is a path to the image to be renamed. Mandatory. 
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It is the most convenient to use for this parameter the 

$(ImageList) variable that is placed by default in the Arguments

field and contains the full name of a processed image.

Example: /imageFile=$(ImageList)

You can also assign to the /imageFile parameter the full name

of an image file via forming the future image name using the

saving settings. We will show how to make it at the next step.

Example: /imageFile="D:\Original\image.jpg"

/visibleColumns are numbers of the columns that will be

indicated in theRenameFileByXL window and used for

searching. The numbers of columns 0, 1, 2, 3... correspond to

naming in letters A, B, C, D... in the xls file Mandatory.

Example: /visibleColumns=0,1,2

/nameColumn is a number of the column the values from which

will be used as an image name. Mandatory. 

Example: /nameColumn=0

/hasHeaderRow gets the value true of false. The table in the

xls file may contain a title. It should be excluded from the

search. true means the first line of the table is not considered in

the search, false means it is. By default, the false is active.

In our example, the table contains a title that is to be excluded

from the search, so we have to set true for  /hasHeaderRow. 

Example: /hasHeaderRow=true

/destDir is a path to the folder where the renamed photos will

be stored. If the folder is not indicated, the renamed photos will

be stored to the folder with the original photos. Optionally. 

Example: /destDir="D:\Result"

The full argument string will have, in our example, the following

appearance:
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Version 1 with use of the $(ImageList) variable and the Start in

field:

/excelFile="15BT81544827.xls" /imageFile=$(ImageList) /visibl

eColumns=0,1,2 /nameColumn=0 /hasHeaderRow=true /destD

ir="D:\Result"

Version 2 with full names of the files:

/excelFile="C:\Program Files\ReFileXLS\XLS

files\15BT81544827.xls" /imageFile="D:

\Original\image.jpg" /visibleColumns=0,1,2 /nameColumn=0 /h

asHeaderRow=true /destDir="D:\Result"
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Please activate the Run automatically after file processing setting. After that, you will see near the

RenameFileByXL name the text [post-processing], that means the tool will be run automatically

after processing.

Please pay attention to that if the Run automatically after file processing setting is disabled,

RenameFileByXL will not be run.
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Then press the OK button to save the connecting settings.

Done! The tool is connected.
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Shooting, Processing and Saving of Image
Open the File menu > Options > Save file.
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Please indicate the folder where the made and processed image to be stored.

If you have appointed the $(ImageList) variable to the /imageFile argument, please leave the other

settings unchanged. 
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If you have appointed a line with file name to the/imageFile argument, you also have to enter the

image prefix and deactivate the counter. The image prefix is to be the same as the file name

assigned to /imageFile. The path to the folder for saving images must also be the same as the path

to the folder indicated in the /imageFile parameter.
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The saving settings are described in details in the Image Saving section.

Press OK.
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Make a shot. For this purpose, press the Capture to File button. The processing settings are

described in details in the Processing Settings and Processing chapters.
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After pressing Capture to File, the image will be made, processed and stored into the indicated

folder.

If the $(ImageList) variable has been assigned to the /imageFile argument, the file name will be

formed from the number of the counter. In our example, it is 001.

If a line with image name has been assigned to the /imageFile argument, the file name will be

formed from the stated prefix.
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The RenameFileByXL tool will be run automatically in 1 or 2 seconds.
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Renaming a File
When you are opening RenameFileByXL, the Search field is automatically gaining the focus.

Please start to enter in this field the second name of the student whose record you need to find.
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If the table contains only one record corresponding to the inquiry, just press OK and the photo file will

be renamed.

If the table has several lines indicated, highlight the necessary one manually. After that, the OK

button becomes accessible. Press it and the photo file will be renamed.
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Open the folder indicated for storing renamed files and check the result of renaming.

In our example, the number 6 corresponds to the second name ANGYER. As you can see on the

image below, the file name has changed from 001 to 6.



inPhoto ID Webcam

226

Chapter 9. Profiles
You can save the application settings in the profile to apply them in the future. Suppose we need to

regularly make photos for two different tasks. E.g., to use them on badges and in questionnaires.

Camera setting, framing setting, image sizes, folders for saving the results and other settings for

these tasks will significantly differ. So, in order to avoid changing multiple settings each time, you can

create corresponding profiles that contain a set of settings for a separate task in each of them. Then,

you can change application settings simply switching over the profile.

The commands for working with profiles are located in the Admin main menu and in the Profile side

menu.

The following operations can be carried out in the Admin menu:

· Create profile

· Update profile in correspondence with the settings of the current application session

· Run Profile Manager where you can:

· Take a look at the existing profiles list

· Take a look at the list of settings for each profile

· Apply the profile to the current application session

· Rename the profile

· Delete the profile

In the Profile side menu you can:

· Take a look at what profile is applied to the current application session

· Change the selected profile

· Reset the profile applied to the current session

· Take a look at whether the application settings have been changed after applying the profile.

You can see an asterisk next to the profile name on the Profile button if the settings have

been modified.
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The contents of the chapter are as follows:

Profile Creation and Setting

Profile Manager

Profile Updating

Working with Profiles from the Side Menu
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Profile Creation and Setting
To create a profile, do the following:

1. Select the New Profile item in the Admin main menu.
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2. In the appeared wizard window, check the required set of settings.

All application settings save all application settings contained in all located below sets of settings.

Crop frame settings save settings of image construction. Settings of image construction include

settings of the size, shape, position of the face frame and of the crop frame. Frame settings can be

found in the ID Image Processing dialogue of the toolbar under the window Source Image and of

the Frame tab.

Please remember that the ID Image Processing dialogue may be called up from the File
menu > Processing settings or from the side menu by the Processing settings button.
The Processing settings button from the side menu may be hidden if the main window of
the program is switched to compact mode. To change window mode, please open the
context menu on the preview and select View > Window Mode. For more details on main
window modes, please see the Main Window Mode chapter.
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You can find out more on the crop frame settings in the ID Image Processing dialogue and Frame

Setting sections.
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Image resizing settings save settings of the resulting image size, i.e. the image after processing.

The settings of the resulting image size are located in the Result Image Size section of the ID

Image Processing dialogue. More details on image compression parameters after processing may

be found in the  Processed Image Size section.
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Image correction settings save such image settings as brightness, contrast, gamma, sharpness

and grayscale. Image correction settings are located in the  Correction tab of the ID Image

Processing window. More details on image correction settings may be found in the Image

Correction section.
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Application options saves all the settings present in the Options window. Please remember that

the settings window is accessible from the main menu File -> Options.

You can know what settings are included in a menu item using the profile manager. The profile

manager is located in the Admin main menu > Profile Manager. Further details on the profile

manager may be found in the Profile Manager chapter.
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3. Let's complete the process of profile creation.

After you have selected the settings that you want to save in the profile press Next. Enter the title of

the future profile in the opened window.

4. Then press Next again. It’s done! The profile has been created.

Enter the profile manager to see the created profile.
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Profile Manager
Profile manager allows carrying out the following operations:

· Take a look at the existing profiles list 

· Take a look at the set of settings for each profile

· Apply the profile to the current application session

· Rename the profile

· Delete the profile

To run the profile manager, enter the Admin menu > Profile Manager.
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Displaying Profile List

You can find the list of all existing profiles in the manager window as shown in the picture below.
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Displaying Set of Profile Settings

To view the contents of the set of settings for the created profile, select the profile from the list on the

left. Then the textual representation of all settings saved for that profile will appear on the right.
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Apply Profile to the Current Session of the Program

There are two ways of applying profile to the current session of the program - using the profile

manager and or using the side menu of the main window.

text
The Profile button may be hidden using the Show Profile button interface setting. The
setting is located in the  File main menu > Options> General tab.

The first way: select the required profile from the list in the profile manager window and press Set.
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Then the message on successful application of the profile will appear and the profile name will be

updated in the side menu.
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The second way: close the profile manager using the Close button. Press the Profile button in the

side menu of the main window. Select a profile different from the current one in the appeared list.
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After this, the selected profile will be applied and the name will change on the Profile button in the

side menu.
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Profile Renaming

To change the profile title, select the required profile in the list on the left and press Rename. 
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Enter a new profile name in the appeared window and press OK.

After that, the message on the successful renaming of the profile will appear.

The title will also change in the profile manager list.
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Profile Deleting

To delete the profile, enter the profile manager, select the required profile from the list and press 

Delete.
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Further, the message asking for the confirmation of the profile deletion will appear. Confirm deletion

by pressing OK.

After that, the message on the successful deletion of the profile will appear.

The deleted profile will no longer be available in the profile manager.
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Profile Updating
The Update Profile command saves the settings of the current session in a selected profile.

Please note that only those settings are being updated in the profile which have been selected in the

profile for saving during creation. So, for example, updating of correction settings will in no way

influence the profile containing the framing settings.

To update profile, change corresponding settings in the application. Then select Update Profile in

the  Admin menu.
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There is a list of all existing profiles in the appeared window. Select the profile to be updated and

press OK.

If the profile has already been established and then the application settings have been changed, this

will be shown with an asterisk next to the profile name in the side menu. Please note that the profile

only reacts to the change of those settings which correspond to the settings saved in the profile.
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For example, the Admin profile in which the framing settings Crop frame settings have been saved

is set in the application. Let's change zoom in/out value in the processing settings and press OK.
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An asterisk will appear in the side menu next to the profile name reminding that the settings

corresponding to the selected profile have been changed.

In case of changing the settings not related to Crop frame settings, the asterisk will not appear next

to the Admin profile.
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Profile Applying
To apply the profile, press the Profile button in the side menu, then select the required item in the list

that appeared.

text
The Profile button may be hidden using the Show Profile button interface setting. The
setting is located in the File main menu > Options> General tab.
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The profile established for the current session you can also reset in the side menu. For this purpose,

choose the Reset profile item from the drop-down list. After applying Reset profile, the application

settings will remain the same as in the last applied profile.

If no profile has been applied to the current session of the program, this item will not present in the

list.
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Chapter 10. Locking
The possibility is provided for inPhoto ID Webcam to lock certain functions of the program.

Locking allows to protect the settings of the camera and the application from undesirable changes;

the shooting and processing functions remain accessible in this case.

Locking activation limits access to the following functions of the application:

· Options located in the main menu File -> Options.

· Processing settings located in the main menu File -> Processing settings.

· Camera settings, Camera format located in the main menu View -> Camera settings, as
well as in the side menu.

· Switch between Window mode and Compact mode.

· Change the main window size.

· Rotate image.

· Commands for working with Profiles.

· Locking settings without Block on Exit.

· The ID Image Processing dialogue that appears during processing has not the Set and the
Set as default button. The Set button opens Resizing Options dialogue, the Set as
default button saves the settings set in the dialogue as by default settings.

The following application functions remain accessible:

· Capture to TWAIN, Capture to File, Capture to Clipboard, located in the main menu

Camera and in the side menu.

· Update AE/AF, Select camera, Reconnect, located in the main menu Camera. Update

AE/AF is also located in the side menu.

· The tools for working with the preview: Grid, Cross-Hair, Exposure control, located in the

main menu Live View.

· Preview window is located in the main menu View.

· The commands of scale changing are located in the main menu View.
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· All commands in the  menu: Help, Send Error Report, Check for Updates, About.

· The Frame and Correction settings located in the ID Image Processing dialogue when the

dialogue is showed during processing. It should be remind that you cannot call the dialogue

using the Processing settings command if the locking switch on.

· Profile is located in the side menu. This command allows to apply, change or reset the

profile for the application. 

The contents of the chapter are as follows:

Scheme of Working with Locking

How to Set Password

Locking

Unlocking

Block on Exit
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Scheme of Working with Locking
Step 1. The administrator sets the application settings, e.g.: camera settings, processing settings,

interface settings, file saving settings, frame and image correction settings...

Step 2. After completion of setting inPhoto ID Webcam, the administrator enters the password and

activates the locking. After that, the application settings will be inaccessible for changing. 

Please see further in the How to Set Password and Locking sections how to set the password

and activate the locking.

Step 3. To the locking will be activated automatically during the next start of inPhoto ID Webcam,

the administrator can switch on the Block on exit setting. This setting excludes the possibility

when the administrator can forget to switch on the locking after he has configured the application. 

Please see further in the Block on Exit section how to activate locking upon closing the program.

Step 4. After the administrator has made settings for the application and activated the locking, the

user can only use the application functions that are not locked. Please remember the locking limits

access for the users to the camera and application settings, shooting and processing commands

remain accessible.

Step 5. When you need to change some settings, the administrator deactivates the locking and all

the application functions become accessible. Then he changes the settings and activates the

locking again.

Please see further the Unlocking section to find out how to deactivate the locking.
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How to Set Password
To set password, follow these steps: in the Admin menu, select the Password item then, in the

appeared window, enter password in the Password field, re-enter password in the Confirm field,

close the window by pressing the OK button.

To change password, deactivate locking if it is activated, then set new password.
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Locking
To activate locking, in the Admin menu, select the Block Parameters item.
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After you have activated locking the blocked menu items and buttons will be disabled.
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Unlocking
To deactivate locking, in the Admin menu select the Unblock Parameters item then enter the

password that you have set in the appeared window and press the OK button.
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Block on Exit
The Block on exit command activates locking upon closing the program. Therefore, the locking will

be activated upon the next start-up of the program.

This command is implemented to reduce the likelihood of leaving the locking off after changing

program settings.

To activate locking upon closing, select the Block on exit item in the Admin menu.

text
It is important to note that the locking will only be activated if the program is completely
closed, if the program is hidden to tray the locking will not be applied.
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Chapter 11. Version Upgrade
inPhoto ID Webcam developers regularly add new options to the application, optimize the current

features and fix the bugs identified.

For keeping the user always updated on a new version release, the application has a feature of

checking for updates. The check can be set to the automatic or to the manual mode. In the automatic

mode, the application checks availability of a new version itself and informs on it during the next start-

up.

In the manual mode, the user can check for availability of a new version at his/her convenience.

It should be reminded that all the custom settings of the user from the previous version remain

unchanged when installing updates.

So, let's take at look at how to check and install updates in each of the modes:

Automatic Mode

Manual Mode

Updates Installation
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Automatic Mode
To enable the updates check in the automatic mode, enter the File menu > Options > General tab.

Then, select the required value for the Check for Updates setting.

If you choose the Weekly value, the application will check for availability of a new version each week,

if Monthly is selected — each month.

If you set the Never value for the setting, the application will neither check for updates nor inform the

user on release of a new version.

This option may be useful if the user prefers to check for updates manually.

After having set the required value, close the Options window with the OK button.
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If you set Weekly or Monthly, the program will check for updates after clicking OK.

If any updates are available, the program will.inform you about it with the following message.

To update version of the program, click the Yes button in the message. You can read more details

on downloading new version in the Updates Installation chapter. To continue working with the

current version, click the No button in the message.
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Manual Mode
You can manually check for updates using the Check for Updates command located in the Help

menu.
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If a new version has been released, as in the automatic mode, the application will inform you about it

with the following message.

To update version of the program, click the Yes button in the message. You can read more details

on downloading new version in the Updates Installation chapter. To continue to working with the

current version, click the No button in the message.

If updates have not been released, the application will inform you that you have the latest version.
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Updates Installation
So, if the application has declared a new version release in the manual or the automatic mode, press

Yes for its installation. After this, the application will forward you to the developer's website where the

link for downloading the new version of the application is available.

Download and install the application.
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text
More details on installing inPhoto ID Webcam may be found in the Installation chapter.

You can see that the version of the application has been upgraded in the About inPhoto ID Webcam

information window which is called up from the Help menu > About.

If you have any questions or suggestions regarding the work of the application, please write us.

Please refer to the Support chapter to find out how to do it.
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Chapter 12. Support
This chapter will describe where the main data on the application are located, how to call up

background information, how to send an error report to the developers, how to create a request in the

users support system and where to find additional information on the work with inPhoto ID Webcam

and with our other products.

The contents of the chapter are as follows:

About the Application

Help Topics

Send an error report

Contact technical support service

Useful Information
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About the Application

The basic information on the inPhoto ID Webcam is located in the main menu   > About.
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The About inPhoto ID Webcam window indicates:

· the title of the application

· its current version

· the name of the development company

· the company's website and email address

· the serial number of the product
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Help
To get the necessary information at any moment of working with inPhoto ID Webcam, use the help

guide. The help guide is located in the  main menu > Help.
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Send an Error Report
If you experience a problem with inPhoto ID Webcam, you can send a report to the developers. The

report contains the data in the application state it was when there was the problem.

To send an error report to the developers, please access main menu  > Send Error Report.
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In the opened form, please fill in the fields. They are described further.

The Details button opens a log file with the description of the application status at the moment of the

error and the preceding events list.

The Save Report button allows to save the report sending data in the text format.

The Add comment field is designated for describing the error. For example, on the picture above, it

contains the comment "ID software continues to give errors when I try to transfer captured

photo with TWAIN.". Please note that the more detailed description is provided in the field, the

quicker the developers are able to correct the error.

Send screenshot allows to take a screen shot and attach it to the report.

Send application settings sends application setting status together with the report.

If the option Notify by email with new information about this issue is enabled, the information

regarding the error will be received onto the specified e-mail address. Please indicate your e-mail

address in the report, this will help the developers to better and quicker solve problems that may

arise. The address may be indicated in the field below.

After the problem has been described and the required options have been set, please press the 

Send Report button and the report will be sent.
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Contact Technical Support Service
We provide users of all our products with full technical support.

You may ask a question or write about an issue using one of the following options:

1. Create a request in the support support service: http://idphotocapture.com/support/. This

way is preferable as the request system allows to save, organize and easily track data.

The algorithm of creating a request in the support system is described below in Creating

a request in the support system section.

2. Via the feedback form on our website: http://idphotocapture.com/support_links/

3. Write an e-mail to the developers to the address: support@idphotocapture.com

The contents of the section are as follows:

Creating a request in the support system

Registration in the support system

Requests created

http://idphotocapture.com/support/
http://idphotocapture.com/support_links/
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Creating a Request in the Support System
To create a request, please click the link: http://idphotocapture.com/support/

Then select the Submit a ticket button.

At this stage, check the Product Support box and press Next.

http://idphotocapture.com/support/
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In the appeared form, fill in the fields with your data. The data on the picture are given by way of

example.

Full Name — enter your name

Email — enter the e-mail address to which you wish to receive information on this request

Priority — select request priority level

Product — select the name of the product in question.

Version — indicate the product version

Serial Number — enter the serial number of the product. It should be recalled that the Serial

Number is indicated in the application information window located in main menu  > About.
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Operation System — choose the operation system of the PC inPhoto ID Webcam is installed on.

If Other, please specify — if your operation system is not in the list provided, specify its name in

this field. Also you need to indicate here other technical data which developers may need to answer

your request.

If the request subject is not related to inPhoto ID Webcam, the Camera Model and Printer Model

fields are not to be filled in. These fields are intended to the requests related to other our products.

Subject — indicate the request subject. In the text field below, please provide a detailed description

of the question or the issue.
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Add File — allows to attach screen shots or other files to the request

After having completed the input, please check the data correctness and press Submit.

After that, the request will be accepted.
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You will receive an e-mail onto the specified address, that is to confirm registration of your request.

The letter will contain a link, click it and you'll be able to view the request status.

text
Please note that to access the request information, you need to be registered in the
support system. The registration procedure is described in more details below in the 
Registration in the support system.

After you have received a letter that your request has been received, please wait for response from

our support service specialists.
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Registration in the Support System
To register in the support system, please click the link http://idphotocapture.com/support and press the

Register button.

http://idphotocapture.com/support
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In the appeared registration form, fill in the fields with your data. The data on the picture is given by

way of example. After having completed the input, please check the data correctness and press 

Sign Up.
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The registration is successfully completed. Then, to enter the support service system, please enter

your e-mail address and password in the login form, then press Login.

After that, a message confirming your signing up will be sent to the specified e-mail address.
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Requests Created
text
To access request information, you need to be registered in the support system.

To view, edit or check status of the request created, enter the system with your login and password.

Then open the View Tickets section containing all data on requests.
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You can also get access to a request via the link from the e-mail which the system sends to your e-

mail address right after creating a request.
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Useful Information
Additional information that can be useful when working with identification photos as well as answers

to frequently asked questions can be found on our website in the Solutions menu by following this

link: http://idphotocapture.com/solutions/.

We recommend the users of inPhoto ID Webcam to start from the following topics:

Identification card

Describes the systems of identification card creation.

Photo identification

Gives examples of the identification cards requiring identification photos. Also the main requirements

to the photos for documents are provided.

Facial Recognition Systems

http://idphotocapture.com/solutions/
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Describes the way of facial recognition and the criteria that an image must meet in order to you

receive high-quality processing results.

Biometric Identification

This topic is about biometric methods of personal identification in images and video. Also, the

examples of tasks that may be solved with such an identification are provided.

Remote Shooting

The article describes how the Remote Shooting process is organized. In addition, you can read here

about application of the Remote Shooting option in such cases as Identification Photo, Studio

Photography, Microscopy, Hard-to-access places, Light-box Shooting, Jewelry Photography,

Astrophotography and Copy Stand and Macro Imaging.

Camera Control

This article describes remote control of a digital camera from a PC. We also describe here such

camera options as Shooting mode, Image format, Zoom, White balance, ISO value, Focus mode,

Flash mode and Flash compensation.

Webcamera Still Image Capture

This article is about creation of identification photos using webcam.
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Conclusion
We hope that working with inPhoto ID Webcam will be comfortable and productive for you.

Please contacts us if:

· you experience problems with the inPhoto ID Webcam operation

· you have questions, comments or suggestions in the process of using the application

· you need advice on choosing a software and a hardware for working with images

We are always here to help you.

IDPhotoCapture.com

e-mail: info@idphotocapture.com

http://idphotocapture.com

mailto:info@idphotocapture.com
http://idphotocapture.com
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