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Introduction
Dear User,

Thank you for choosing IDPhoto Processor!

IDPhoto Processor is a program that allows you to batch process your photos. It provides fast and

accurate face detection and image cropping based on your settings. From a set of different images

of multiple sizes, IDPhoto Processor enables you to  easily prepare photos  for  passports,  driver’s

licenses,  school  and college passes,  badges,  employee  ID  cards,  entrance  passes,  military  IDs,

visas, pension IDs, licenses, health insurance cards, national ID cards, loyalty cards and many other

identification documents.

The software performs the following tasks as part of the process:

Opens each image from the source folder

Automatically recognizes the face on the image

Crops the photo according the proportions specified

Resizes the image to the required measurements

Corrects the photo for contrast, sharpness, brightness and gamma

Saves the results to the designated folder

Transfers images through the TWAIN driver

Photos can be processed using either fully automatic or semi-manual mode.
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IDPhoto Processor supports the following file formats:

JPEG/JPG

BMP

PNG

GIF

TIFF

To obtain the best results from the software, you are advised to use images that:

are taken in a well-lit environment

include the whole head, from the top of the hair down to the shoulders

have a single-color background

have a natural, relaxed facial expression

are full-face

have no shadows on the face or background

have no additional items, such as sunglasses or hats, covering the face or head.

We hope that this guide will help you quickly familiarize yourself with the program and make use of

the full range of its capabilities.
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Chapter 1. Start of Work
The contents of the chapter are as follows:

Installation

Start-up

Activation

Installation
The  IDPhoto Processor  application is  being installed on a computer  online  using  the  installation

wizard.

Run the installation package file (a file with exe extension) to start the installation process.

Step 1. Select the language of the application interface in the window appeared and press OK.

Step 2. In the next window, the wizard recommends you to close all the active applications. This will

enable the application to update system files without restarting the PC. Press Next to continue the

installation.
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Step 3. At this step, you should read the licence agreement. Read it carefully and press I agree if

you agree with all the clauses. Once this is done, the installation of the application will continue. If the

licence agreement is not accepted, the installation will be cancelled.
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Step 4. At this stage, the wizard offers selecting a folder to which the application will be installed.

Press Install to start installing the application.
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Step 5. At this step, the application installation window will appear. The installation process may take

some time. Please wait until it has completed. After the installation has completed, the wizard will

automatically move to the next step.

Step 6. In this dialogue, the wizard offers creating a desktop shortcut for the application. The

application shortcut is added to the Start menu and to the list of TWAIN drivers in any case during

the installation. If you also wish to add the shortcut to the desktop, press Yes, if the shortcut in the

Start menu is enough, press No.

Step 7. This is the last step of the wizard. Here it informs you that the application has been installed

on the computer. Press Finish to complete the installation.
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Done!  IDPhoto Processor has  been installed.  Run the IDPhotoProcessor.exe  application file  to

start working with the application.

The next Start-up chapter describes how to start up IDPhoto Processor.

Start-up
IDPhoto Processor can be started in several ways:

1. Starting up IDPhoto Processor from Start Menu.

Press Start; then choose the IDPhoto Processor item in the appeared menu and press it.
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2. Starting up IDPhoto Processor from the Desktop.

This start-up option is possible if you have chosen to add the desktop shortcut for the application

during the installation. In such a case, just find the shortcut on the desktop and double-click it using

the left mouse button.
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3. Starting up IDPhoto Processor from the Application Folder.

Open the folder to which the application has been installed (this is C:\Program Files\IDPhoto

Processor by default) and start up the IDPhotoProcessor.exe file by double-clicking it.
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4. Starting up IDPhoto Processor via TWAIN Connection. 

IDPhoto Processor can also be started using a third-party application via TWAIN connection. This

mechanism is described in more details in the Process to TWAIN chapter.

Activation
When starting up IDPhoto Processor  for  the first  time,  the activation wizard window  will  appear.

Here you can choose to:

Use the application in demo mode

Purchase the licence

Activate the licence

Close the application

All  other  details  on  using  the  application  in  the  demo  mode  and  on  purchasing  the  licence  are
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described further in the Demo Mode and Purchase of the Licence chapters.

If you have already purchased the licence, its activation will  confirm  the authenticity of  the installed

copy and open access to all the application features.

There are two ways of licence activation: Online and Offline. If the Internet connection is available

on the PC where the application is installed on, the Online activation will be selected automatically; if

not, then use the Offline activation. The activation procedure is described in details further in the

Activation Online and Activation Offline chapters.

The contents of the section are as follows:

Demo Mode

Purchase of the Licence

Activation Online

Activation Offline
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Demo Mode

The user has access to all the application features in the demo mode.

There is a limitation: all received images will contain a demo sign.

The  demo  mode  allows  trying  the  application  at  work  and  assessing  its  capabilities  before

purchasing. 

To start up the program in demo mode, press the Continue with Demo button.
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Purchase of the Licence

If you wish to activate the application, but have not purchased the licence yet, choose the Buy

License button.

After that, the application will forward you to the developer's website where you can buy the licence to

the required product.
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Activation Online

 
This way of activation requires Internet connection.

Upon initial launch of IDPhoto Processor, an activation wizard window appears. Press the Activate

button to start activation of the application.

Please verify the name of the application being activated is the same as the name of the application

indicated with the Serial Number.

Then enter the Serial Number and press the Activate button.
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After  that,  the application will  attempt  to  connect  to  activation  servers.  Several  servers  are  made

available  for  ensuring  the  reliability  of  connection.  If  the  PC  is  connected  to  Internet  and  the

connection succeeds, the activation of the application is completed. The activation wizard will inform

you about it with the following message:
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If the PC is not connected to Internet, Offline activation window will appear.
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Activation Offline

If the PC on which IDPhoto Processor is to be activated is not connected to Internet, then make use

of the Offline activation. In such case, Serial Number validation is carried out via server,by the same

way as when the Online  activation used. The difference is that you may use any PC or device with

Internet  connection  for  sending  the  Serial  Number.  It  is  not  mandatory  to  be  the  PC  IDPhoto

Processor has been installed on. For example, a user having no access to Internet from his/her job

computer may activate the application using a phone or home computer. There are no constraints as

to the time between sending the Serial Number to the server and entering the received reply code in

IDPhoto Processor activation window. This can be done within any time period.

Upon initial launch of IDPhoto Processor, an activation wizard window appears. Press the Activate

button to start activation of the application.

Please verify the name of the application being activated is the same as the name of the application

indicated with the Serial Number.

Then enter the Serial Number and press the Activate button.
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In the appeared window, please write down or copy the data from the Serial Number and Activation

Code fields. These data are to be sent to the activation server. It is  to be recalled that there are no

constraints as  to  the time between sending the data to  the server  and entering the received reply

code in  IDPhoto Processor  activation window.  You may complete  the  Offline  activation  at  your

convenience.
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You will need Internet connection to proceed with the activation.

Use your browser to open the page specified in the field  2.  From any computer  with  an Internet

connection, open the activation page.
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Enter your Serial Number and Activation Code in the corresponding fields of the appeared form and

press the Activate button.

 Please note:  the data should be entered in  the same format  as  they have been presented in  the

activation wizard window, i. e. by groups of 4 digits without spaces, separated by hyphens. 

After having completed the input, press the Activate button.
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After that, the Authentication Code will be generated. Write it down or copy for subsequent entry into

the activation wizard field.
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If the data are entered incorrectly, the Authentication Code will consist only of  zeros.  In  such case,

please check correctness  of  the data and the input  format.  Please note,  your  Serial  Number  and

Activation Code should be entered by groups of 4 digits without spaces, separated by hyphens.
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Enter the received Authentication Code in the field 4. Enter your Activation Code and then press

the Activate button.
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Now, the Offline  activation is successfully completed.  The application will  inform  you about  it  with

the following message:
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Chapter 2. Interface
The contents of the chapter are as follows:

Main Window View

Interface Setting

Shorcuts

Work Completion

Main Window View
The main window of IDPhoto Processor is the user’s interface composed of six main elements.

The user can set the application window according to his/her needs and convenience.
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Let's take a closer look at each of these elements.

The contents of the section are as follows:

Window Title

Main Menu

Explorer Setup Toolbar

Side Menu

Status Bar

Explorer
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Main Menu

The main menu is designed for accessing different application functions.

The File menu contains interface settings, image processing settings, resulting images saving

settings, and external tools connection settings.

The Explorer menu contains the Explorer appearance settings: type of file view, icon sizes and the

Select all option.

The Actions menu contains the list of the connected external applications. As you can see on the

picture, Paint.NET is connected to the application in this case. An application can be added or

deleted in the File menu -> External tools tab. Refer to the Chapter 5. External tools chapter for

more details on working with external applications.

The Capture menu contains features of saving processed images to TWAIN, a file and a clipboard.

The Process to TWAIN item is disabled by default. You need to establish connection with the
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TWAIN driver to enable it. Please refer to the Process to TWAIN section for more details on saving

data in TWAIN.

The Help menu contains help topics, update checks, application information and the function of

sending an error report to the product developers.

The Admin menu contains functions for working with profiles.

Window Title

The title of the window traditionally contains the application name and Minimize, Change window

size, and Close buttons.

Explorer Setup Toolbar

The explorer setup toolbar contains a set of functions designated for setting up explorer appearance
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and for convenience of explorer navigation.

The toolbar includes the following elements:

A folder tree

A key for moving up to the parent folder

A button for explorer area update

A search box displaying the highlighted file name

A drop-down for selecting extensions of the file which may be displayed or concealed in the explorer.
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Side Menu

The  side  menu  is  created  to  bring  additional  convenience  to  the  application  interface  and  for  a

quicker access to the frequently used functions.

The appearance of the menu depends on the interface settings located in the File  menu > Options

> General tab > User Interface Settings section.
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By default, the interface is set in such a way that not all, but only the most  frequently used buttons

are displayed in the menu.

text
If the Process to File and Process to Clipboard buttons are not active, select one or
several images in the explorer.

Let's take a closer look at the functions of each button.

The  Process  to  TWAIN,  Process  to  File  and  Process  to  Clipboard  buttons  run  the  image

processing process with subsequent saving of the results. Actions started with the buttons differ only

by locations to which the processing results will be saved. Process to TWAIN saves the processed

images to the application or the device with which the connection is established through the TWAIN

driver.  If  the connection through the TWAIN driver  is  not  established,  the button will  not  be active.

Process  to  File  saves  the  processing  results  to  the  specified  place  on  the  drive.  Process  to

Clipboard saves images to the clipboard.

More details on the processing process may be found in the Processing chapter.

 

The Processing settings button calls  up the ID  Image  Processing  dialogue that  contains  all  the

settings regulating image processing: face detection settings, bounding box and subsequent framing

settings, correction settings, resulting image size settings.  More details  on the processing settings

may be found in the Processing Settings chapter.
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The Profile button calls up the menu consisting of the list of all profiles created in the application and

the  Reset profile item. The menu allows applying or cancelling the profile for the current application

session. To apply the profile, just select it from the list. Then, the specified profile will be displayed on

the Profile button. To reset the profile, choose the Reset profile  item from the menu. After that, the

profile name will disappear from the Profile  button. If the Reset profile  item  is  not  available  in  the

menu, the profile for the current application session is not set. More details on working with  profiles

may be found in the Profiles chapter.
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Close button closes the application or minimizes it to tray depending on the status of the Hide to

tray instead of close setting. More details on closing the application may be found in Work

Completion chapter.

For  your  convenience,  the  side  menu  interface  in  TouchScreen  devices  may  be  made  button-

operated. For this purpose, enter  the File  menu>  Options  >  General  tab and enable the Enable

Touchscreen controls setting.
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Status Bar

The status  bar  is  meant  for  displaying the information needed in  the course of  work.  This  area is

divided into four sections. In the first section, the name of the highlighted image is displayed from left

to right. The second one provides the information on the amount of the space occupied by the image

on the drive. The third one is about image size in pixels. The fourth one displays the amount of free

space on the drive. 

More details on saving images may be found in the Saving Processed Images chapter.

If no image is selected in the explorer, only the amount of free space on the drive will be displayed in

the status bar. If multiple images have been selected at a time, the information on the last image will

be shown in the status bar.
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Explorer

The explorer  is  an  image  file  manager.  It  allows  saving  images  to  TWAIN,  a  file  or  a  clipboard,

running an external application, calling up image properties window. Select one or several images to

make the listed options available.

Selection of images in the IDPhoto Processor explorer is carried out with the same combination of

buttons which is used for selecting objects in the Windows operating system.

Ctrl + A allows selecting all images in a folder at a time. All photos can also be selected through the 

Explorer main menu > Select all.

To select a range of images, press and hold Shift button; with holding Shift button simultaneously,

select the first and the last images of the range with the mouse.

To select several separate images, press and hold Ctrl button; simultaneously with holding the Ctrl

button, select the required images with your mouse.
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To deselect the images,  please also use the Shift and Ctrl buttons.

Interface Setting
The setting of  main window  interface in  IDPhoto Processor  is  flexible.  The  user  can  choose  to

change appearance of  the side menu and  the  explorer  as  well  as  to  switch  the  language  of  the

interface.

Let's take a closer look at how it works.

The contents of the chapter are as follows:

Side Menu Interface

Language Switching

Explorer Appearance

Side Menu Interface

The side menu is designated for more convenient and quicker access to the frequently used

functions.
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All the side menu interface settings are located in the File menu > Options > General tab > User

Interface Settings section.
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By using settings from this section, you can display or hide any button from the side menu except for

the  Processing settings button. Displaying of only the most frequently used buttons is set by

default. The table with the setting names and respective displaying buttons is given below.

Show capture to TWAIN button Process to TWAIN

Show capture to File button Process to File

Show capture to Clipboard button Process to Clipboard

Show Profile button Profile

Show Close button Close

The last setting in this section is Enable Touchscreen controls; it changes the side menu interface

to the one that is more convenient for the usage in touch-screen devices.
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Language Switching

You can select and set the application interface language in the File main menu > Options >

Language tab. The English, French, German and Russian languages are currently available.
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For switching to the necessary language, select it from the list and close the dialogue with OK

button. Then, the application will inform you that the selected language will be applied upon the next

start-up of the application.

Explorer Appearance

Now we only have explorer appearance settings that have not been viewed. They are located in the 

Explorer  menu,  in  File  menu  >  Options  tab  >  Explorer  and  in  the  toolbar  located  above  the

explorer.

In the Explorer tab, you can find the Show file extension setting. You can use it to enable and
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disable displaying file extensions in the explorer.

The features allowing you to select explorer view and icon size are presented in the Explorer menu.

The last element located in the upper panel also influences the explorer appearance. It allows
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selecting the formats of files that will be displayed in the explorer and the formats of files that will be

hidden.
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Shorcuts
You can get access to many IDPhoto Processor commands not only from the menu, but also using

shortcuts. If a shortcut corresponds to a certain menu item, then it is indicated on the title of this

item.

The full list of the shortcuts and commands related to them is provided below.
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Alt+O Calls up the Options dialogue window

Alt+X Closes IDPhoto Processor

Ctrl+A Selects all files and folders in the explorer

F4 Starts up  Process to TWAIN

F5 Starts up  Process to File

F6 Starts up  Process to Clipboard

F1 Calls up the help file

Esc
Closes  the  ID  Image  Processing  dialogue  and

interrupts processing if it has been started.

Work Completion
There are four ways to complete IDPhoto Processor operation. 

The first way: enter the File menu and choose Exit. This command always finishes work of the

application irrespective of the value of the Hide to tray instead of close setting described below.

The second way is applicable if the application is minimized to tray. In this case, call up the context

menu on the application icon and choose Close.
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The behaviour of the application when closing it in the two following ways will depend on the value of

the  Hide to tray instead of close setting.

Hide to tray instead of  close  replaces  closing IDPhoto Processor  by minimization to  tray.  The

setting  influences  closing  of  the  application  with  the    button  in  the  main  menu  title  and  its

automatic  closing after  processing if  the Close  after  processing  setting  is  enabled.  The  setting

does not  influence closing the application through the File  main menu >  Exit.  The application will

always close when using Exit.

Hide to tray instead of close is located in the File main menu > Options > General tab. The

setting is enabled by default.

The third way: enter the File menu> Options > General tab and enable the Close after

processing setting. If this setting is enabled, the application will complete its work after processing.

Whether the application will close completely or will be minimized to tray depends on the value of the 

Hide to tray instead of close setting described above.
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The fourth way: complete the work of the application with the  button in the window title. Whether

the application will close completely or will be minimized to tray depends on the value of the Hide to

tray instead of close setting.
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Chapter 3. Processing Settings
Processing is the key function of the application. This chapter will describe all processing functions,

settings and options in IDPhoto Processor.

The processing procedure can be divided into several stages. 

Downloading photos from the selected source.

Automatic face detection and framing. 

Setting up image composition (aspect proportions, face positioning, rounded corners etc.).

Parameters of photo volume, quality and size after processing.

Image correction (setting up contrast, brightness, gamma etc.).

Setting up carrying out  of  the processing procedure  if  no  face  has  been  detected  on  the
photo. 

Saving processing results.

The contents of the chapter are as follows:

General Settings

Saving Processed Images

ID Image Processing dialogue

Actions

Statistics

Processing Completion
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General Settings
The settings regulating carrying out of the processing procedure can be found in the Options

dialogue of the Processing tab.

Image processing allows enabling or fully disabling image processing. When it is  enabled, you can

select a processing parameter in the drop down below. For IDPhoto Processor, this  parameter  is

face finding.

Show processing window setting regulates in which cases the image processing dialogue should

be shown to a user.

Show  if  necessary  means  that  the  dialogue  will  be  called  up  only  if  the  user's  interference  is

required. If the face has been found and the outer box of the frame fits completely in the image, the

processing was successful and no dialogue will be shown to the user. If the face is not  found or  is

found, but  is  too close to  the image border  while  the outer  box is  not  fitting in  the image then the

application will call up the dialogue, so that the user is able to make corrections manually and choose

a further action. This may include saving the image with default settings or with settings modified by

the user, skipping the image or cancelling the whole processing procedure.
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Always  means  that  the  processing  dialogue  will  always  be  shown.  Also  in  those  cases  when

processing  is  going  well.  This  application  behaviour  allows  the  user  to  control  the  processing

procedure. 

Newer  means  that  the  processing  dialogue  will  not  be  called  up.  This  option  is  applied  when

complete withdrawal of human involvement in the processing procedure is required. In such a case,

the user can initiate processing and be off, then come back when the result will  be ready.  So what

happens with the images that failed to be processed?

If a  face is  not  detected on the photo,  the image will  be saved without  changes,  i. e.  the resulting

image will not differ in any way from the original one. When the face is found, but the outer box does

not fit in the image, the image will be cropped after its predifined borders.

In the scenario with Newer value, it is  practical to  use the Place  unprocessed files in  following

folder option.  It  allows  collecting all  unprocessed images  in  one folder  and then processing them

manually. For manual processing, change the value from Newer to Always.

Auto  face  detection  is  the  last  section  on  this  tab.  Only  Enabled  setting  is  contained  here;  it

indicates  whether  the application will  search a face during the processing or  not.  The  processing

mode with enabled search may be required when the user prefers outlining the face area by himself/

herself. For example, this is convenient for the photos of several persons. In such a case, it is  more

practical  to  search  the  face  in  the  processing  dialogue  manually.  Then  all  other  operations,  like

framing, size setting etc., will be carried out manually.

Saving Processed Images
It is necessary to set up the saving parameters of the resulting images before starting the processing

procedure. The settings can be found in the File menu > Options > Save file tab.
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Let’s look at what settings can be found within the Destination section.

Place modified files in  source  folder  saves  processed images  to  the same folder  in  which the

source photos are located.

Place  modified  files in  follow folder  saves  processed images  to  a  specified  folder.  The  folder

must have enough free space for the images, and the access to it should be allowed. The path to the

folder is indicated in the box below the setting.

Destination format: allows selecting format in which the processed image will be saved.

Place unprocessed files in follow folder allows saving the files which have not  been processed

for any reason in the specified folder. One of the possible reasons is that no face has been detected

on the photo.

File options is the next section.

Overwrite  existing  files  option  depends  on  the  selected  value.  If  Replace  is  selected,  the

application  will  replace  the  source  image  with  the  processed  one.  If  Ask  is  selected,  then  after

processing, the application will show a confirmation message of the file overwriting.
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If Skip is selected, the image will not be overwritten.

JPEG Quality allows defining the compression degree of the image being saved.  It  applies  only to

the files of JPEG format.

Limit size sets the upper margin for the image size. This is measured in kilobytes. If this parameter

is selected, then JPEG Quality will be chosen automatically to fit the file size.

The Remove original files option removes the source files. This option is enabled only if the Place

modified files in source folder option is disabled. Similarly, when the processed images are saved

to the same folder with the source images, the latter are simply to be overwritten.

Remove to Recycle bin option removes the source images to the recycle bin. It allows restoring an

image removed by mistake.

text
Thanks to  this option, you can always restore accidentally removed source images from
the recycle bin.

Set resolution allows setting resolution for JPEG images.Set  resolution allows  setting resolution

for JPEG images.

text
The DPI value is applicable not only for saving images into the file, but also for transferring
them via TWAIN driver.

DPI affects the quality of an image when printing it out. This parameter sets the number of ink dots

that the printer is capable of placing on your image per inch. Based on the image size in pixels and

DPI value, the size of the image to be printed is calculated in the physical units (inches, centimetres

etc.). When reducing DPI, image resolution and details are degraded.
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Finally in the chapter on image saving, it is to be added that metadata of the processed files are fully

saved if they are presented in one of the following formats: exif, iptc, xmp. The metadata written in

other formats are cut off.

Metadata are standardized data on file properties. Metadata of an image normally contain
information on the camera name and manufacturer,  date and time when the photos  were
taken,  GPS  coordinates  of  a  frame,  photo  name,  author’s  name,  image  resolution  etc.
Most of the modern cameras also record shooting settings: shutter speed, aperture, ISO,
using flash, focal length.

ID Image Processing Dialogue
The image processing dialogue contains  face detection,  framing,  adjustments  settings  and part  of

the resulting image size settings. 

The dialogue may be called up in three ways. The first way: File  menu > Processing settings. The

second way: from the side menu by the Processing settings button.
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The third way: the dialogue is called up while the processing is progressing. The user can do it

manually by double clicking on the required image in the explorer with the left mouse button, or the

application will call up the dialogue automatically during the processing.

text

The Show processing window setting determines in what cases the dialogue will be
called up automatically during processing. You can find out more on the application
behaviour settings in the General Settings section.

In the first two cases, the dialogue will open for the standard test image. If you change the settings in

the dialogue for the test image, the new settings will be accepted as the default ones. If you change

the settings in the dialogue called up during processing, then the new settings will be applied only to

the current image. 

Let's call up and view the dialogue of processing for the test image.



Chapter 3. Processing Settings

56

The most part of the space in the dialogue is allotted to the processing result preview window. To the

right, there is an original image view window. Settings are placed in the lower part of the dialogue.

In  the source image  preview  window,  two  bounding  boxes  are  applied  on  the  photo:  the  internal

yellow box and the external one which may be green or red. The internal box outlines the face area.

No bounding box will be present if the face is not detected or the face search is disabled by means of

the application settings.  The face bounding box can be enabled or  disabled  with  the  Face  button

which is  located below  the source image window.  The internal  box can be expanded,  reduced  or

moved to the left, to the right,  up or  down.  This  can be done with  the mouse in  the source image

window  or  through  the  button  toolbar  below  the  window.  All  actions  with  the  internal  box  are

automatically applied to the outer one.

The outer box shows the image margin after which cropping of  the image will  be performed.  If  the

distance between the face area and image margins is smaller than the distance set in the settings,
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then the outer box will be red. For example, if the face is too close to the edge of the photo.

Below the image window there is a toolbar with buttons for setting the boxes. Let's list the buttons it

contains and their respective functions.

The   button  increases  the  area  of  the  face  to  be  outlined  together  with  the  frame  box;

correspondingly, the   button decreases it.

The     arrow buttons move the outlined face area together with the frame box to  the

left, to the right, up and down.

The  button enables and disables outlining the face area.

The  button enables and disables outlining the centre of image.

Then, we'll call up and view the dialogue for the image being processed. Please remember that you

need to double click on the required image in the explorer with the left mouse button.

What distinguishes the dialogue called up during processing from the dialogue for the test image is

the presence of the following elements:

A short name of the file being processed is indicated in the title of the dialogue window. 

A full name of the file being processed is indicated above the source file window. 

OK and Cancel buttons are replaced by the buttons for saving the image, skipping the image

or cancelling the whole process of processing. Please refer to the Actions chapter for more

detail.
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The contents of the chapter are as follows:

Processed Image Size

Frame Setting

Image Correction
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Processed Image Size

The information on image dimensions is contained in the Source Image Size and Result Image

Size sections.

The Source Image Size section shows the size of the source image in pixels.

The Result Image Size section shows the size of the resulting image with the current settings (also

in pixels). The size value will change depending on the change in settings. Resizing is enabled

means that the upper margin for the image size is set. Resizing is disabled means that there are

no restrictions on the maximum size of the resulting image. Click the Set button to set or remove

limits and to set the compression parameters. After that, the Resizing Options dialogue will be

called up.
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To set or remove the upper margin for the image size, use the Set maximum size for resulting

image setting.

The second setting in this section, that is Allow image enlarge, allows enlarging the image to the

specified dimensions if the source image is smaller. In other words, if this setting is disabled, only the

images with bigger original dimensions are scaled to the specified dimensions. If the image

dimensions are originally smaller than the specified ones, the image height and width will remain

unchanged. When the setting is enabled, all the images are scaled to the specified dimensions,

regardless of whether they have initially been bigger or smaller. Please keep in mind that the quality

of the enlarged images may worsen.

The dimensions of the resulting images are set in the Width and Height fields below in the dialogue.
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Frame Setting

The Frame section contains frame composition and size settings.

Let's look at each setting in more detail.

Apply Crop Frame  enables and disables face search and further image framing. When this setting

is  being disabled,  the boxes  from  the source image window  will  disappear,  and the image will  be

displayed in its original form in the result preview window.
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The  processing  procedure  started  with  the  Apply Crop  Frame  setting  disabled  will  apply  to  the

image all the settings except the ones in the Frame section. It can be seen that  when no cropping

after the box is set, all the settings in the section become disabled. 

Zoom is a ratio of face area to the area of the future frame. The value of 40 is selected in the default

settings which means that the face area accounts for 40% of the area of the whole frame. Provided

the value is  increased  to  100,  the  face  area  will  occupy  the  whole  frame.  Let's  show  it  with  an

example. First, to make the frame well-balanced,  let's  match the centres  of  the face area and the

frame area by setting the  Position vert. value to 50 and the hor. value to 50. Then we'll set zoom to

100%.
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Position: moves the frame cropping box vertically and horizontally. For instance, such need may

arise if it is necessary to move the image of a person and add a company logo on the photo. In such

a case, you simply need to move the box in the required direction. Offset values are given in per

cents.



Chapter 3. Processing Settings

64

Size: this setting allows specifying the ratio of the frame sides. E. g., with width to height ratio as 4:

4, the frame will have a form of a square. To specify the sides ratio, just indicate the required frame

dimensions.
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Frame effect is the list of effects that can be applied to the image frame. There is only one

Rounded corners effect in the list at present. Click the Settings button placed to the right of the list

to change the settings of this effect. In the shown dialogue window, you may set the rounding radius

and background colour for the corners.
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Reset is the last button in this section which makes it possible to cancel changes of all the settings

and return them to default state.
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Image Correction

All settings for image correction are placed within the Correction tab.

Here  you  can  set  such  parameters  of  photo  as  brightness,  contrast,  gamma,  sharpness,  and

greyscale. All changes of the settings will be displayed in the preview window.

Brightness —  this  parameter  indicates  how much  do  image  pixel  colours  differ  from  the  black

colour.  E. g.  the brightness of  the photo taken in sunny weather will  be significant  and  visa  versa

that of  the photo taken in the evening or at  night  will  be low.  Brightness is  set  in the range from -

100 to 100.

Contrast is  one of  the main image parameters,  it  regulates  pixel brightness.  When increasing  the

contrast, the light areas (pixels) of  the image become lighter,  while the dark  ones become darker.

And visa versa,  when reducing contrast,  dark  pixels  become  lighter,  while  the  light  ones  become
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darker and partially move to midtones. Contrast is set in the range from - 100 to 100.

Gamma — this image parameter allows changing colour intensity of  dark  pixels  to a greater extent

than that of  light  ones.  In other words,  it  is  possible to increase contrast,  distinctness of  the dark

areas of the image, while not mak ing light details of the photo too contrast or bright.

Sharpness is also one of the main image characteristics;  it  indicates  the quality of  reproduction of

large fragments on the photo. Increasing sharpness is one of the common ways of  improving image

quality.  Actually,  increasing of  the  sharpness  decreases  the  width  of  the  borders  between  image

areas with different brightness. The narrower the border, the sharper looks the photography.  This  is

reached by lightening lighter pixels on one side of  the border and by darkening the darker ones on

the other side.

Grayscale  —  this  option  allows  mak ing  black-and-white  photo  from  the  colour  one.  In  the

Grayscale  mode,  all  the  colours  are  cancelled  for  the  image  and  only  information  on  pixel

brightness is saved. Furthermore, all the colours on the photo are transferred to the grayscale.

The Reset button makes it possible to cancel changes of all the settings and return them to default

state.
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Actions
If the processing procedure runs without calling up ID Image Processing  dialogue,  the processing

will be completed automatically. In such a case, the user does not need to take any actions.

If  during processing,  the dialogue will  be called up,  the user  needs  to  choose one of  the possible

actions  after  the process  is  completed.  Possible  actions  are  represented  by  the  Set  as  default,

Skip, Save, Back and Close buttons.

Let's view each option in more detail.

Set as default saves the image with the settings set for the current application session. It is possible

to set the settings for the current application session in  two ways.  The first  way:  call  up ID  Image

Processing dialogue from  the main or  side application  menu,  change  the  values  of  the  required
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settings  and  click  OK.  The  second  way:  set  the  profile  with  the  required  parameters  for  the

application through the main or side menu. 

Skip skips the processing of the current image and moves to the next one.

Save saves the photo with the settings set in the dialogue.

Back interrupts the processing procedure.

Close skips the processing of the current image and moves to the next one.

The Esc key on the keyboard performs the same function as Back and Close  buttons.  This  option

closes the ID Image Processing dialogue and interrupts processing if it has been started. 

For stopping the processing by means of the Esc key, the application will ask for the confirmation.

Statistics
If processing is started for several images, then after the process completion, the application will

display a message with statistics.

The message informs on how many images have been processed, how many of them have been

processed successfully, on how many of them no face is detected and for how many of them the

processing has been cancelled.
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If the processing has been started only for a single image, then the message will not be displayed.

The statistical information displaying can be enabled/disabled with the Show Processing Statistics

setting which is located on the File main menu > Options > Explorer tab.

The setting is enabled by default.
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Processing Completion
After completing the processing procedure, the application can be closed or minimized to tray. Such

behaviour is regulated with the Close after processing and Hide to tray instead of close settings.

The settings are located on the File main menu > Options > Explorer tab.

Close after processing completes the work of IDPhoto Processor after processing. If the Hide to

tray instead of close  setting is disabled, IDPhoto Processor will be closed; if enabled, then it will

be minimized to tray.

Hide to tray instead of close changes closing IDPhoto Processor to minimization to tray.

Chapter 4. Processing
In the previous chapters, we have described all functions and settings for image processing. Now, it

is time to run the process and take a look at how it progresses.
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There are three types of image processing in the application: Process to TWAIN, Process to  File

and Process to Clipboard. In all three cases, the processing process is identical and it is  only the

last action that differs. For Process to  TWAIN,  this  is  sending an image to  the application or  to  a

device through the TWAIN driver.  The results  transfer  through the TWAIN driver  will  be  described

below with the XnView image viewer taken as an example. For  Process to  File,  this  is  saving an

image to the specified folder on the drive. For Process to Clipboard, this is saving an image to the

clipboard.  In  this  case,  it  is  convenient  to  paste the image into  a document  or  another  application

without interim saving.

It should be reminded that Process to File can be run not only for files, but also for subfolders.

You can interrupt the processing process by pressing the Esc key on the keyboard.

So, let's take a closer look at each saving method.

Process to TWAIN

Process to File

Process to Clipboard

Process to TWAIN

Contents of the section:

About TWAIN

An Example of Process to TWAIN

About TWAIN

TWAIN  is  the  software  protocol  that  makes  it  possible  to  directly  transfer  images  from  image-

capturing devices, like scanners and digital cameras, to applications.

Without TWAIN, you would first need to copy and save the image to  a disc  and only after  that  the

user application will be able to open it.

Thanks to TWAIN, application software and image-capturing devices can understand each other and
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interact.

Image-capturing devices work via TWAIN data source usually called TWAIN  driver.  Not  only a  real

device, like scanner and digital camera, but a software as well can serve as a data source.

The following IDPhotoCapture products support the work as data sources:

inPhoto ID Webcam

inPhoto ID PS

inPhoto ID SLR

IDPhoto Processor

inPhoto Capture PS

inPhoto Capture SLR

TWAIN  protocol  comes  with  a  data  transfer  standard  and  API  interface.  TWAIN  drivers  are

applications  for  managing  image-capturing  devices  written  on  the  basis  of  the  TWAIN  interface.

Normally,  TWAIN  drivers  have a graphical  interface and  function  as  a  data  source  control  panel.

TWAIN drivers also allow configuring image settings, such as  colour  balance,  size,  gamma range,

etc.  before  the  image  is  received  by  the  application.  Sets  of  settings  in  TWAIN  drivers  differ

depending on a data source device.

Image transfer with TWAIN involves user application, supporting TWAIN protocol to which the image

will be transferred and TWAIN driver which serves as an image source. Most applications for image

handling are currently supporting TWAIN, however please refer  to  the application supplier  or  to  the

documents to find out about such a possibility.

Only application can initiate an image transfer, so it is from this that the TWAIN call have to start.

Various  applications  have  their  own  commands  for  receiving  files  from  a  data  source.  Normally,

these  commands  are  found  in  the  File  menu  and  labelled  as  Acquire  or  Import.  In  some

applications,  you  need  to  previously  indicate  a  data  source.  For  this  purpose,  a  TWAIN  source

command is used which is also normally found in the File menu.

Diagram of image transfer via TWAIN.

1. A user selects and starts the TWAIN driver from the application to which the image is to be
transferred.

http://idphotocapture.com/products/inphotoid-webcam/
http://idphotocapture.com/products/inphotoid-ps/
http://idphotocapture.com/products/inphotoid-slr/
http://idphotocapture.com/products/idphotoprocessor/
http://idphotocapture.com/products/inphotocapture-ps/
http://idphotocapture.com/products/inphotocapture-slr/
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2. After a TWAIN driver call, the application enters the standby mode and waits for response of
the driver on the image readiness for being transferred. The application may be locked in
standby mode. In reality, the behaviour of each application may differ and depends on the
features included into it by developers.

3. While the application is waiting, the driver becomes a main controlling unit. The user
manages a data acquisition device and captures an image.

4. After the image is captured, the driver transfers it to the waiting application.

5. After the transfer process is finished, the application may demand to close the driver. Further
transfer via TWAIN is impossible with closed driver. For re-transferring the image, you need
to start the procedure from the very beginning, calling out the driver from the application
again.

An Example of Process to TWAIN

The  Process to  TWAIN  command processes  images  and  transfers  them  to  external  application

which connected to IDPhoto Processor via TWAIN protocol. As an application in which processed

photos will be transferred we use image viewer XnView.

It should be reminded that IDPhoto Processor is an image source in TWAIN connection. 

So, we start IDPhoto Processor and select several images in the explorer. 

Unlike the rest  of  the  program  functions,  the  Process  to  TWAIN  button  and  the  menu  item  are

disabled. 
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This is right. The possibility to transfer images via TWAIN driver will arise when IDPhoto Processor

receives a request from the third-party application for opening TWAIN connection.  By this  moment,

the Process to TWAIN elements will be disabled.

Let's open TWAIN connection and enable Process to  TWAIN  function.  For  this  purpose,  we start

XnView, enter File main menu and select Select TWAIN source.
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In the appeared Select Source dialogue, we select IDPhoto Processor from the source list.

Then, in the same File menu, we select Acquire.
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If by that moment, IDPhoto Processor has been closed or minimized to a tray, now it will be started.

We  connected  to  TWAIN  driver  of  IDPhoto  Processor  via  XnView.  We  move  to  IDPhoto

Processor and select several  images  in  the explorer.  Please note that  Process to  TWAIN  menu

item and button now have been enabled.

text
Process to TWAIN may be disabled if no images are selected in the explorer.

text
For more details on selecting objects in the explorer, see chapter Explorer.



IDPhoto Processor 3 - User Guide

79

Having selected required images, we start Process to TWAIN.

Process to TWAIN may be started from Capture  main menu > Process to TWAIN, from the side

menu by clicking Process to TWAIN button, or from the context menu in the explorer.

The  Process  to  TWAIN  button  from  the  side  menu  may  be  hidden  if  the  application
interface is set up in such a way. To make the button visible, enter File menu > Options>
General tab and set up Show Capture to TWAIN button. For more details on setting of
the side menu interface, see chapter Side Menu Interface.

Further course of processing depends on the settings set by the user. Please note that the key

processing settings are located in the File main menu > Options > Processing tab.
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If Always is selected in the settings, then the ID Image Processing dialogue will be called up for

every image being processed.

If the dialogue opening setting is set to the Show if necessary value, the dialogue will be opened only

if a user's participation is needed for processing the images. The dialogue will not be opened for

successfully processed photos.

If the Never option is selected, processing will be carried out without opening the ID Image

Processing dialogue. Images that cannot be processed automatically will remain unchanged. 

You can read more details on settings and actions on the ID Image Processing dialogue in the

General Settings, ID Image Processing dialogue, and Actions chapters.
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After completing the processing procedure, we return to XnView and look at the result of the

command Process to TWAIN. As can be seen on the picture, the images are successfully

processed and transferred to the viewer.
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The process of connecting to  other  applications  via  TWAIN  driver  is  similar  to  that,  exemplified by

XnView.  It  is  noteworthy  that  applications  may  close  the  channel  for  TWAIN  driver  after  image

transfer is completed. Because of this, Process to TWAIN button will be disabled. To enable it, you

need to repeat the process of selecting a scanner.

XnView can also accept several images at a time, as it was demonstrated in the example. Not all the

applications  support  this  option.  For  some applications,  you have to  start  the processing for  each

separate image.

Please note that IDPhoto Processor is set by default as to be minimized to tray after processing

completion. More details on settings regulating processing completion may be found in the 

Processing Completion section.

Process to File
The Process to File command carries out processing of files and subfolders with their subsequent
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saving to the specified place on the drive. The command can be started from the Capture main

menu > Process to File, from the side menu by pressing the Process to File button or from the

context menu in the explorer.

The Process to File button may be hidden in the side menu, if the application interface is
set  up in  such the way.  To  make  the  button  visible,  enter  the  File  menu  >  Options  >
General tab and set the Show Capture to File button setting. More details on the setting
of side menu interface may be found in the Side Menu Interface chapter.

text

text
If the Process to File item is not active, select one or several images in the explorer.

So, select one or several images and start up Process to File in any way.
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Further course of processing depends on the settings set by the user. Please note that the key

processing settings are located in the File main menu > Options > Processing tab.
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If Always is selected in the settings, then the ID Image Processing dialogue will be called up for

every image being processed.

If the dialogue opening setting is set to the Show if necessary value, the dialogue will be opened only

if a user's participation is needed for processing the images. The dialogue will not be opened for

successfully processed photos.

If the Never option is selected, processing will be carried out without opening the ID Image

Processing dialogue. Images that cannot be processed automatically will remain unchanged. 

You can read more details on settings and actions on the ID Image Processing dialogue in the

General Settings, ID Image Processing dialogue, and Actions chapters.



Chapter 4. Processing

86

Thus, with the default settings, the application will display a message with statistics upon the

process completion. The message informs on the successful completion of the process as well as

on the number of images processed, on the number of those processed successfully, those on

which no face has been detected, and those for which processing has been cancelled.



IDPhoto Processor 3 - User Guide

87

The display of the message with statistics is regulated with Show Processing Statistics
setting located in File main menu > Options > Explorer tab.

If the processing has been started for a single image, such a message will not be displayed.

Then, to see the processed images we enter the folder indicated in saving settings. Please note that

the saving settings are located in the File menu > Options > Save file tab > Destination section.
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In this example, 4 images have been sent to processing.

The result looks like this. You can see in the picture that all photos have been successfully

processed and saved.
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You should be reminded that by default IDPhoto Processor is set as to be minimized to tray after

the processing completion. More details on settings regulating processing completion may be found

in the Processing Completion chapter.

The contents of the chapter are as follows:

Processing of Folders with Subfolders

Processing of Folders with Subfolders

There is a possibility in IDPhoto Processor to run Process to File not only for files, but for

subfolders as well. This option may be enabled or disabled using the Process subfolders setting

located in the File menu > Options > Explorer tab.
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Process to Clipboard
The Process to Clipboard command processes and saves images to the clipboard. As opposed to

Process to TWAIN and Process to File, only one image can be saved to the clipboard.

The command can be started from the Capture main menu > Process to Clipboard, from the side

menu by pressing the Process to Clipboard button or from the context menu in the explorer.

By default, the application interface is  set  in  such a way  that  the Process to  Clipboard
button is hidden on the side menu. To make the button visible, please enter the File menu
> Options > General tab and set the Show Capture to Clipboard button setting. More
details  on the setting of  side menu interface may  be found in  the  Side  Menu  Interface
section.

text

text
If the Process to Clipboard item is not active, select the required image in the explorer.
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So, let's run the Process to Clipboard command and take a look at how it works.
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Further course of processing depends on the settings set by the user. Please note that the key

processing settings are located in the File main menu > Options > Processing tab.
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If Always is selected in the settings, then the ID Image Processing dialogue will be called up for the

image being processed.

If the dialogue opening setting is set to Show if necessary, the dialogue will be opened only if a

user's participation is needed for processing the images. The dialogue will not be opened for the

successfully processed photos.

If the Never option is selected, processing will be carried out without opening the ID Image

Processing dialogue. Images that cannot be processed automatically will remain unchanged. 

You can read more details on settings and actions on the ID Image Processing dialogue in the

General Settings, ID Image Processing dialogue, and Actions chapters.
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Upon processing completion, the image is placed into the clipboard. To see the result, let's  paste the

processed image from the clipboard into Microsoft Word, for example. 

For this purpose, please open Microsoft Word and press Paste on the Home tab of the main menu.

After that, the processed image will be pasted into the document. The result is  shown in the picture

below.
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Please pay attention that  when running Process to  Clipboard  for  several  photos  at  a  time,  all  of

them will be processed while only the last one will be placed in the clipboard.

In such a case, a message offering to select only one photo for saving to the clipboard will be shown.

Also when processing a series of photos, a message with statistics will be shown at the end.
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If processing has been started for a single image, such a message will not be displayed. More details

on the statistical data may be found in the Statistics section.

Please note that IDPhoto Processor is set by default as to be minimized to tray after processing

completion. More details on settings regulating processing completion may be found in the 

Processing Completion section.
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Chapter 5. External tools
There is  a  possibility  for  connecting  external  applications  to  the  IDPhoto  Processor  application.

Such feature makes further work with photos automatic while also allowing you to call up the required

tool for the specified image. 

Connection of external applications is carried out under form of adding new items to the Actions

menu. By default, the menu consists of only one item for adding a new application — [New External

Tool].
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Connecting, editing and deleting of external applications are carried out through the File menu >

Options > External tools tab. The tab contains parameters for connecting to an external

application.

text
If the boxes are not active, select the required application or the [New External Tool] item
from the External tools list.
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Let's take a look at the function of each parameter.

The External tools box is the list of connected applications.

The Title box is designated for the application title. The user may choose it at his/her own discretion.

The title selected will be displayed in the Actions menu.

In the Command box, you need to indicate the path to the application file or package file. Here you

can state files with the exe, com, bat, cmd extensions.

The Arguments box contains command line arguments. Upon calling up an external application, the

ImageList argument will be changed to the list of the file names. The file name to be indicated fully,

including the path, and to be enclosed in quotes. Please use a space as a separator between the

names. For example: "d:\portrait1.jpg" "d:\portrait2.jpg" "d:\portrait3.jpg".

Directory - in this box you have to indicate the path to the working folder of the external application.

Most of the applications do not use this parameter, but there are some cases when it is mandatory.

Execute after processing parameter enables and disables start up of an external application after

completing image processing. This parameter can be set only for one application at a time. If you
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assign Execute after processing first for one application and then for another one, then at the

moment of setting the parameter for the second application, it will be reset for the first one.

Add and Delete serve for adding and deleting external applications respectively.

 In the next sections of this chapter, we'll describe the work with external application by example of

the Paint.net graphics editor and the Blat e-mail client.

The contents of the chapter are as follows:

An Example with Paint.net Image Editor

An Example with Blat Email Client

An Example with Paint.net Image Editor
In this example, we'll connect the Paint.net image editor and demonstrate its work in manual and

automatic modes. The connection with graphics editor is useful when you need to additionally edit

photos after processing.

The contents of the chapter are as follows:

Connection

Manual Mode

Automatic Mode

Editing and Deleting

Connection

Add Paint.net  to the list of external applications of IDPhoto Processor.

Open the File menu > Options > External tools tab. Select the [New External Tool] item in the

External tools box.
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Let's state the editor title and the path to its executable file as shown in the picture below.

text
Your path to PaintDotNet.exe may differ from the one shown in the example.

Please note that in the Title box, you can enter any name for stating the editor. The value entered to

Title will become the title of the corresponding item in the Actions menu.

More  details  on  external  application  connection  options  may  be  found  at  the  beginning  of  this

Chapter.

After filling in the Title and Command boxes, the application will appear in the External tools list.
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To complete establishing connection, press Add, then close the dialogue window with the OK button.

Now, Paint.net is connected and added to the Actions menu.
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Manual Mode

Let's demonstrate the operation of Paint.net in the manual mode. 

For this purpose, select several images in the explorer, then open the Actions menu and run the

editor.
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As can be seen in the picture below, Paint.net has started up successfully and opened the selected

images. Please note that we had not run the processing process, and the editor has opened the

selected images without any changes.
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Automatic Mode

Running Paint.net  in  the  automatic  mode  allows  opening  images  in  the  editor  immediately  after

processing without any interim actions by the user.

Let's demonstrate the operation of Paint.net in the automatic mode. 

For this purpose, open the File menu > Options > External tools tab in IDPhoto Processor and

set the Execute after processing setting.

text

Execute after  processing  setting can be set  only  for  one  application  at  a  time.  If  you
assign Execute after processing first for one application and then for another one, then at
the moment  of  setting  the  parameter  for  the  second  application,  it  will  be  automatically
disabled for the first one.
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The [post-processing] option will appear in the application list next to the Paint.net title. It informs

you that the automatic running after processing for the application is enabled. Then, we select

several photos and run the processing process, for example, through Process to File.
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Further  application behaviour  depends  on the processing process  settings.  It  should  be  reminded

that they are located in the File menu > Options > Processing tab.

Thus, if the Show processing window setting is set to Always, the setting dialogue will be called up

for each photo being processed.

Upon the Show if necessary value set, the setting dialogue will be called up only for photos whose

processing requires a user's participation.

If the Never value is chosen, the dialogue will not be called up.

More details may be found in the General Settings section.

After the processing, the first image will be opened in Paint.net.
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At this time, a completion waiting window for the external application operation will appear in IDPhoto

Processor.

The waiting window  will  close automatically after  completion  of  the  external  application  operation.

This mode is useful when working with command line utilities. If an external application is  to  be left

running,  press  Continue  to  go  on  working  with  IDPhoto  Processor.  In  our  example,  it  is  more

convenient  to  process  and  open  all  images  at  once  in  the  editor,  so  we'll  return  to  IDPhoto

Processor and press Continue  in the dialogue window. Now, IDPhoto Processor will not wait for



Chapter 5. External tools

110

Paint.net being closed, but will move on to processing the next photos.

The result can be seen in the picture below.

Upon completion of the processing, IDPhoto Processor will display a message informing on

successful completion of the process as well as on the number of images processed, the number of

those processed successfully, of those on which no face has been detected and of those with

processing cancelled.

You can see from the message that the number of photos processed corresponds to the number of
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photos opened in the editor.

Editing and Deleting

To change the parameters of Paint.net connection, select it in the External tools list, change

parameter values and close the dialogue with OK.

To delete the application, select it from the External tools list, press Delete and close the dialogue

with OK.
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An Example with Blat Email Client
In  this  example,  we'll  connect  the Blat  email  client  and  demonstrate  its  operation  in  manual  and

automatic modes. The connection with the email client is useful when you need to email photos after

processing.

Blat is a command-line utility, so the batch file is needed for working with it.

Create a batch file with bat extension and place it to the same folder where blat.exe is located. An

example of the file contents is shown in the picture below. 

More details on the syntax of the batch file in Blat can be found in the developer website or the utility

accompanying documents. It should be noted here just that the number of files being sent is

indicated at the end of the file with the following parameters: %1,%2,%3,%4. Further in the example,

we'll attach various number of files to the email, so this parameter will change. For sending one

attached file, the parameter will look like this: %1, to increase the number of the attached files you

only have to add them with % sign separated by commas. Thus, for sending 4 files, the entry will look

like this: %1,%2,%3,%4.
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After creating the bat file, you can move on to connecting the application.

The contents of the chapter are as follows:

Connection

Manual Mode

Automatic Mode

Editing and Deleting

Connection

To add Blat to the list of external applications, enter the File  menu > Options > External tools tab.

The tab contains parameters for connecting external applications. 

More details on the parameters may be found in this chapter.



Chapter 5. External tools

114

For the boxes to become active, the application should be selected from the External tools list. As

we are connecting a new application, let's select [New External Tool].

Fill out the Title  and Command boxes. Write the utility title in the Title  box. Please note that in this

box you can enter any name for indicating the application. The value entered to Title  will become the

title of the corresponding item in the Actions menu. In Command, let’s indicate the path to the bat file

created at the beginning of the example.

After filling in the Title and Command boxes, the application will appear in the External tools list.
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To complete establishing connection, press Add, then close dialogue window with OK button.

Blat has now been connected and added to the Actions menu.
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Manual Mode

Let's demonstrate the operation of Blat in the manual mode. 

For this purpose, we select several images in the explorer, then open the Actions menu and run the

email client.

Please pay attention that the bat file contains information on the number of files that will be
attached  to  the  email.  Make  sure  that  the  number  of  files  indicated  in  the  bat  file
corresponds  to  the  number  of  images  sent  for  processing.  If  the  number  does  not
correspond, change the bat file. More details on the contents of the bat file may be found at
the beginning of the example.
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The result of the Blat  operation is  seen in  the picture below  -  the email  with  the attached images

reached the addressee successfully. The subject and contents of the email also correspond to those

specified in the bat file.

It should be reminded that we have not run the processing process, and the images have been

emailed without any changes.
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Automatic Mode

Running Blat in the automatic mode allows sending images by email immediately after processing

without any interim actions by the user.

text
Please note that the external application is called up after  processing every  image in  the
automatic mode. Thus, each processed image will be sent in a separate email.

Let's demonstrate the operation of Blat in the automatic mode. 

Since here we'll  attach only one file  to  the email  (unlike the example with  the manual  mode),  let's

change this parameter in the bat file.

More details on the contents of the bat file may be found at the beginning of the example.
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Now we return to IDPhoto Processor and set the Execute after processing setting for Blat.

The [post-processing] parameter has appeared next to Blat in the External tools list. It informs us

that the automatic running after processing is enabled for the application. 

text

Execute after  processing  setting can be set  only  for  one  application  at  a  time.  If  you
assign Execute after processing first for one application and then for another one, then at
the moment  of  setting  the  parameter  for  the  second  application,  it  will  be  automatically
disabled for the first one.
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Let's select several images and run the processing process, for example, through Process to File.
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Further application behaviour depends on the processing process settings. Please note that they are

located in the File menu > Options > Processing tab.

Thus, if the Show processing window setting is set to Always, the setting dialogue will be called up

for each photo being processed.

With the Show if  necessary value set,  the setting dialogue will  be called up only for  photos  with

processing requiring a user's participation.

If the Never value is chosen, the dialogue will not be called up.

More details may be found in the General Settings section.

When executing the batch file, IDPhoto Processor will display the waiting window for the completion

of the external application operation.
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The wait window will close automatically after the operation of Blat has been completed.

As we have run processing for several images, IDPhoto Processor will display statistical report

upon the process completion. Please note that after processing of a single image, the report will not

be displayed. The report informs on the total number of images processed, on the number of those

processed successfully, of those on which no face has been detected, and on those for which the

processing has been cancelled.

Let's check the email after the IDPhoto Processor and Blat operations have been completed. As

planned, 4 emails have been received to the email address indicated in the bat file, each containing

the processed image.
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Editing and Deleting

To change the parameters of Blat connection, select it in the External tools list, change parameter

values and close the dialogue with OK.

To delete the application, select it from the External tools list, press Delete and close the dialogue

with OK.
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Chapter 6. Profiles
Profiles allow saving a set of application settings in  order  to  use them  again.  Suppose we need to

regularly process photos for two different tasks. E.g., to use them on badges and in questionnaires.

Framing setting,  image sizes,  folders  for  saving the results  and other  settings  for  these tasks  will

significantly  differ.  So,  in  order  to  avoid  changing  multiple  settings  each  time,  you  can  create

corresponding  profiles  that  contain  a  set  of  settings  for  a  separate  task  in  each  of  them.  Then,

application settings will be changed by simply switching over the profile.

The tools for working with profiles are located in the Admin main menu and in the Profile side menu.

The following operations can be carried out in the Admin menu:

Create profile

Update profile in correspondence with the settings of the current application session

Run Profile Manager which allows the following operations to be carried out:

Take a look at the existing profiles list

Take a look at the list of settings for each profile

Apply the profile to the current application session

Rename the profile

Delete the profile

The following operations can be carried out in the Profile side menu:

Take a look at what profile is applied to the current application session

Change the selected profile

Reset the profile applied to the current session

Take a look at whether the application settings have been changed after applying the profile.

You can see an asterisk next to the profile name in the Profile side menu if the settings have been

modified.

The contents of the chapter are as follows:

Profile Creation and Setting

Profile Manager
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Profile Updating

Working with Profiles from the Side Menu

Profile Creation and Setting
To create a profile, select the New Profile item in the Admin main menu.

The profile creation wizard will be called up. Check the required settings in the wizard window. They

will be described with more details below in this chapter.
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You can check what  settings  are included in  a  menu  item  using  the  profile  manager.  The  profile

manager  is  located  in  the  Admin  main  menu  >  Profile  Manager.  Further  details  on  the  profile

manager may be found in the Profile Manager chapter.

So, let's take a look at each set of settings separately.

All application settings save all application settings contained in all located below sets of settings.

Crop frame  settings  save settings  of  image construction.  Settings  of  image construction include

settings of the size, shape and position of the face frame and of the crop frame. Frame settings  can

be found in the ID Image Processing dialogue of the toolbar under the window Source Image  and

of the Frame tab.

text

Please remember that the dialogue may be called up from the File menu > Processing
settings or from the side menu by the Processing settings button.
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You can find out more on the crop frame settings in the ID Image Processing dialogue and Frame

Setting sections.

Image resizing settings save settings of the resulting image size, i.e. the image after processing.

The settings of the resulting image size are located in the Result Image Size section of the ID

Image Processing window. More details on image compression parameters after processing may

be found in the  Processed Image Size section.
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Image correction settings save image correction settings. Image correction settings are located in

the  Correction tab of the ID Image Processing window. More details on image correction settings

may be found in the Image Correction section.
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Application options save virtually all application settings excluding image processing settings. This

set of settings includes application window size and position, updates check, main window interface

status, processing results saving settings, parameters of additional connected applications, etc. The

whole list  of  settings  for  this  set  as  well  as  the  lists  for  other  sets  can  be  viewed  in  the  profile

manager.

Let's complete the process of profile creation.

Press Next after selecting the settings to be saved in the profile. Enter the title of the future profile in

the opened window.
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Then press Next again. It’s done! The profile has been created.

Enter the profile manager to see the created profile.

Profile Manager
Profile manager allows carrying out the following operations:

Take a look at the existing profiles list 

Take a look at the list of settings for each profile

Apply the profile to the current application session

Rename the profile

Delete the profile



IDPhoto Processor 3 - User Guide

135

To run the profile manager, enter the Admin menu > Profile Manager.

To view the contents of the set of settings for the created profile, select the profile from the list on the

left. Then the textual representation of all settings saved for that profile will appear on the right.
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To apply the profile settings for the current application session, press the Set button in the manager

window.

After that, the message on the successful application of the profile will appear.

The title of the profile established for the current application session will be displayed next to the 

Profile button in the side menu.

The Profile button may be hidden using the Show Profile button interface setting. The
setting is located in the  File main menu > Options> General tab.
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To change the profile title, select the required profile in the list on the left and press Rename. Enter a

new profile name in the appeared window and press OK.
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After that, the message on the successful renaming of the profile will appear.

The title will also change in the profile manager list.

There are two ways of applying the profile for the current application session, through the profile

manager and through the side menu of the main window. The first way: select the required profile

from the list in the profile manager window and press Set.
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Then the message on successful application of the profile will appear and the profile name will be

updated in the side menu.
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The second way: close the profile manager using the Close button. Press the Profile button in the

side menu of the main window. Select a profile different from the current one in the appeared list.
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After this, the selected profile will be applied and the name will change on the Profile button in the

side menu.
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To delete the profile, enter the profile manager, select the required profile from the list and press 

Delete.
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Then the message asking for the confirmation of the profile deletion will appear. Confirm deletion by

pressing OK.

After that, the message on the successful deletion of the profile will appear.
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The deleted profile will no longer be available in the profile manager.

There are two ways of updating the Profile button in the side menu. 

The first way: select another profile in the profile manager and press Set.

The second way: close the profile manager with the Close button, then press Profile in the side

menu. Select another profile or the Reset item in the drop-down list. If you select the Reset item, no

profile will be set for the current session.

Profile Updating
The profile  updating allows  applying the settings  of  the current  application session to  the selected

profile.

Please note that only those settings are being updated in the profile which have been selected in the

profile  for  saving  during  creation.  So,  for  example,  updating  of  correction  settings  will  in  no  way

influence the profile containing the framing settings.

To update profile, change corresponding settings in the application. Then select Update Profile in

the  Admin menu.
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There is a list of all existing profiles in the appeared window. Select the profile to be updated and

press OK.

If the profile has already been established and then the application settings have been changed, this

will be shown with an asterisk next to the profile name in the side menu. Please note that the profile

only reacts to the change of those settings which correspond to the settings saved in the profile.
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For example, the Admin profile in which the framing settings Crop frame settings have been saved

is set in the application. Let's change zoom in/out value in the processing settings and press OK.
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An asterisk will appear in the side menu next to the profile name reminding that the settings

corresponding to the selected profile have been changed.
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In case of changing the settings not related to Crop frame settings, the asterisk will not appear next

to the Admin profile.

Working with Profiles from the Side Menu
For your convenience, the option of the profile application is duplicated from the Admin main menu to

the side menu.

To apply the profile, press the Profile button in the side menu, then select the required item in the list

that appeared.

The Profile button may be hidden using the Show Profile button interface setting. The
setting is located in the File main menu > Options> General tab.
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The profile established for the current session can also be reset in the side menu. For this purpose,

choose the Reset profile item from the drop-down list. After applying Reset profile, the application

settings will remain the same as in the last profile.
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If no profile has been applied, this item will not be in the list.
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Chapter 7. Command-Line Interface
The possibility is provided for IDPhoto Processor to perform operations both through the graphic

user interface and the command-line interface. Hereinafter, the command-line interface will also be

named CLI.

text
CLI is the abbreviation of Command-Line Interface.

The user may enter CLI commands directly onto the command-line interpreter or use script files. 

Both ways of interaction are described below in this chapter.

Command-line arguments for IDPhoto Processor are as follows:

/process    Runs image processing from the specified source. It is a default key. 

/source="<path>"    Sets the path to the folder where the source images are located, or directly
to the image file if only one file is to be processed.

/saveas="<path>"    Sets the path to the folder where the processed images are saved.

/profile=<profile>     Sets the profile with the specified name.

If /source, /saveas and /profile parameters are not set, then IDPhoto Processor applies values of

the corresponding settings which have been set through the window interface of the application. 

Through the CLI, you can start processing of a single file, several files or a directory. Examples are

given for each case below in this chapter.

Contents of the Chapter:

An Example with cmd.exe

An Example with a Batch File

Examples for processing a single file, several files or a directory

An Example with cmd.exe
In this example, we'll run processing of the images under  IDPhoto Processor  from  the command
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line. 

Step 1. Run cmd.exe.

cmd.exe is the command-line interpreter. The user can interact with the operating system
and  the  application  programs  supporting  the  command-line  interface  through  the  cmd
character-based interface. The utility is on the same drive on which the operating system is
installed, normally the С drive, by the following way: Windows\System32.

Step 2. Using  the cd command, move to the folder where IDPhoto Processor is installed:

cd C:\Program Files (x86)\IDPhoto Processor
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Step 3. We describe the processing scenario in cmd.exe. For this purpose, assign the following

parameters: /process - to process, /source="<path>" - the path to the folder where the source files

are located, /saveas="<path>" - the path to the folder where the processed files need to be placed.

text

If you want to process not the whole directory but one or more specific images, some
examples of entries for different cases can be found in the section Examples for
processing a single file, several files or a directory.
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Please  pay  attention  that  the  directory  path  should  not  contain  any  extra  separators  –
slashes – in the /source and /saveas parameters. For example, the following entry will be
invalid and will cause an error: /source=D:\Portraits\ /saveas=D:\Result\ 
The correct entry should look like this: /source=D:\Portraits /saveas=D:\Result

IDPhotoProcessor_CLI.exe /process /source=D:\Portraits /saveas=D:\Result

Step 4. Press Enter in cmd.exe, this action will start processing in IDPhotoProcessor_CLI.exe.

Depending on the settings, the application may display the ID Image  Processing  dialogue and the

confirmation for overwriting the file during processing. 

More details on the Show processing window setting displaying the ID Image Processing dialogue

may be found in the General Settings and ID Image Processing Dialogue Chapters. 

More details on the Overwrite existing files  setting  displaying confirmation for  overwriting the file

may be found in the Saving Processed Images Chapter.
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Upon completing the processing, a message with the statistical report may be displayed. More

details on the setting which enables displaying of the message and the report information may be

found in the Statistics Chapter.
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If the processing is run for one image, the message with the report will not be displayed.

Step 5. Check processing results. The source images and the images after processing are shown

on the pictures below. Processing has been performed as set in the command-line parameters. The

images from the folder indicated in the /source  parameter  have been processed and saved to  the

folder indicated in the /saveas parameter.
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An Example with a Batch File
To automate the processing process through the command-line interface, we use a batch file. 

We'll write the following script in the batch file: run IDPhotoProcessor_CLI.exe with the  /process

(run processing), /source (the place to take the source files from) and /saveas (whereto to save the

processed files) parameters. 

Step 1. Create a batch file with the bat extension and place it into the same folder where
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IDPhotoProcessor_CLI.exe is located.

Step 2. Create source_path and saveas_path variables in the batch file and assign values to them.

Assign the path to the folder from which the source files are taken to the source_path; assign the

path to the folder into which the processed images are saved to the saveas_path.

text

If you want to process not the whole directory but one or more specific images, some
examples of entries for different cases can be found in the section Examples for
processing a single file, several files or a directory.

Please  pay  attention  that  the  directory  path  should  not  contain  any  extra  separators  –
slashes – in the /source and /saveas parameters. For example, the following entry will be
invalid and will cause an error: /source=D:\Portraits\ /saveas=D:\Result\ 
The correct entry should look like this: /source=D:\Portraits /saveas=D:\Result

:::::: Set variables ::::::
set source_path=D:\Portraits
set saveas_path=D:\Result
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Then describe running IDPhotoProcessor_CLI.exe with the /process, /source and /saveas

parameters. Assign the values of the source_path and saveas_path variables to the /source and /

saveas parameters.

:::::: Run IDPhotoProcessor_CLI.exe with arguments ::::::
start IDPhotoProcessor_CLI.exe /process /source=%source_path% /saveas=%saveas_path%

An example of the file contents is shown on the picture below.

Step 3. Run the batch file.

Depending on the settings, the application may display the ID Image  Processing  dialogue and the

confirmation for overwriting the file during processing. 

More details on the Show processing window setting displaying the ID Image Processing dialogue

may be found in the General Settings section. More details on the Overwrite existing files setting

displaying  confirmation  for  overwriting  the  file  may  be  found  in  the  Saving  Processed  Images

Chapter.
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Upon completing the processing, a message with the statistical report may be displayed. More

details on the setting which enables displaying of the message and the report information may be

found in the Statistics Chapter.
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If the processing is run for one image, the message with the report will not be displayed.

Step 4. Check processing results.

Information on processing and saving images is displayed in the command-line window.

Look at the images in the explorer. 

You can see on the pictures below that the images from the folder indicated in the /source

parameter have been processed and saved to the folder indicated in the /saveas parameter.
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Examples for processing a single file, several files or
a directory
Examples of entries for processing of a single file, several files or a directory are shown in this

section.

Please  pay  attention  that  the  directory  path  should  not  contain  any  extra  separators  –
slashes – in the /source and /saveas parameters. For example, the following entry will be
invalid and will cause an error: /source=D:\Portraits\ /saveas=D:\Result\ 
The correct entry should look like this: /source=D:\Portraits /saveas=D:\Result

Example for processing of a single file

To process a single file, specify the full name of the source file in the /source  parameter, and the full

name of the future processed file in the /saveas parameter.

The entry for cmd.exe: 

IDPhotoProcessor_CLI.exe  /process  /source=D:\Portraits\portrait1.jpg  /saveas=D:\Result

\portrait1_ID.jpg

The entry for a batch file:
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:::::: Set variables ::::::

set source_path=D:\Portraits\portrait1.jpg

set saveas_path=D:\Result\portrait1_ID.jpg

:::::: Run IDPhotoProcessor_CLI.exe with arguments ::::::

start IDPhotoProcessor_CLI.exe /process /source=%source_path% /saveas=%saveas_path%

Example for processing of several files

To process several files, specify the full names of the source files in the /source  parameter and the

path to the directory where the processed files are to be saved in the /saveas parameter.

To list files in the /source parameter, the name of  each file  should be taken in  double quotes  and

separated from other files by means of a space and a vertical bar.

The entry for cmd.exe: 

IDPhotoProcessor_CLI.exe /process /source="D:\Portraits\portrait1.jpg" | "D:\Portraits\portrait2.jpg" |

"D:\Portraits\portrait3.jpg" /saveas=D:\Result



Chapter 7. Command-Line Interface

166

The entry for a batch file:

:::::: Set variables ::::::

set source_path="D:\Portraits\portrait1.jpg" | "D:\Portraits\portrait2.jpg" | "D:\Portraits\portrait3.jpg"

set saveas_path=D:\Result

:::::: Run IDPhotoProcessor_CLI.exe with arguments ::::::

start IDPhotoProcessor_CLI.exe /process /source=%source_path% /saveas=%saveas_path%

Example for processing of a directory

To process  the file  directory,  specify the path to  the directory with  the source files  in  the /source
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parameter and the path to the directory where the processed files  are to  be saved in  the /saveas

parameter.

The entry for cmd.exe: 

IDPhotoProcessor_CLI.exe /process /source=D:\Portraits /saveas=D:\Result

The entry for a batch file:

:::::: Set variables ::::::

set source_path=D:\Portraits

set saveas_path=D:\Result

:::::: Run IDPhotoProcessor_CLI.exe with arguments ::::::

start IDPhotoProcessor_CLI.exe /process /source=%source_path% /saveas=%saveas_path%
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Chapter 8. Version Upgrade
Разработчики  IDPhoto  Processor  регулярно  добавляет  в  программу  новые  возможности,

оптимизируют текущей функционал и исправляют замеченные ошибки.

IDPhoto Processor  developers  regularly add new  options  to  the application,  optimize the current

features and fix the bugs identified.

For  keeping the user  always  updated on  a  new  version  release,  the  application  has  a  feature  of

checking for updates. The check can be set to the automatic or to the manual mode. In the automatic

mode, the application checks availability of a new version itself and informs on it during the new start-

up.

In the manual mode, the user can check for availability of a new version at his/her convenience.

It  should be reminded  that  all  the  custom  settings  of  the  user  from  the  previous  version  remain

unchanged when installing updates.

So, let's take at look at how to check and install updates in each of the modes.

The contents of the chapter are as follows:

Automatic Mode

Manual Mode

Updates Installation

Automatic Mode
To enable the updates check in the automatic mode, enter the File menu > Options > General tab.

Then, select the required value for the Check for Updates setting.
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If the Weekly value is chosen, the application will check for availability of a new version each week, if

Monthly is selected — each month, respectively. When identifying updates, the application will show

the following message.

If the Never value is selected for the setting, the application will neither check for updates nor inform

the user on release of a new version.

This option may be useful when the user prefers to check for updates manually.

Manual Mode
You can check for updates manually in the Help menu > Check for Updates.
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If a new version has been released, the application will display the same message as in the

automatic mode.

If there is no new version, the application will inform on it with the following message.
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Updates Installation
So, if the application has declared a new version release in the manual or the automatic mode,

press Yes for its installation. After this, the application will forward you to the developer's website

where the link for downloading the new version of the application is available.

Download and install the application.

text
More details on installing IDPhoto Processor may be found in the IDPhotoProcessor
Installation chapter.



IDPhoto Processor 3 - User Guide

173

You can see that the version of the application has been upgraded in the About IDPhoto Processor

information window which is called up from the Help menu > About.

If you have any questions or suggestions regarding the work of the application, please write us.

Please refer to the Support chapter to find out how to do it.
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Chapter 9. Support
This chapter will describe where the main data on the application are located, how to call up

background information, how to send an error report to the developers, how to create a request in the

users support system and where to find additional information on the work with IDPhoto Processor

and with our other products.

The contents of the chapter are as follows:

About the Application

Help Topics

Send an error report

Contact technical support service

Useful Information

About the Application

The main information on the IDPhoto Processor application is  located in   the main menu >

About.
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The appeared dialogue window indicates:

the title of the application

its current version

the name of the development company

the company's website and email address

the serial number of the product
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Help Topics
To get the necessary information at any moment of working with IDPhoto Processor, use the help

guide. The help guide is located in the  main menu > Help.
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Send an Error Report

If you wish to send an error report to the developers, please access  main menu > Send Error

Report. In the window that appears there are some options for getting more detailed description of

the problem. Let's take a look at this with more details.
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The Details button opens a log file with the description of the application status at the moment of the

error and the preceding events list.

The Save Report button allows to save the report sending data in the text format.

The Add comment field is  designated for describing the error. For example, on the picture above, it

contains the comment "ID software  continues to  give  errors when I  try to  transfer  captured

photo  with  TWAIN".  Please  note  that  the  more  detailed  description  is  provided  in  the  field,  the

quicker the developers are able to correct the error.

Send screenshot allows to take a screen shot and attach it to the report.

Send application settings sends application setting status together with the report.

If  the option Notify by email  with  new information about  this issue  is  enabled,  the  information

regarding the error  will  be received onto the specified e-mail  address.  Please indicate your  e-mail

address  in  the report,  this  will  help  the developers  to  better  and quicker  solve problems  that  may

arise. The address may be indicated in the field below.

After  the problem  has  been described and the  required  options  have  been  set,  please  press  the

Send Report button and the report will be sent.
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Contact Technical Support Service
We provide users of all our products with full technical support.

You may ask a question or write about an issue using one of the following options:

1.  Create a request  in  the support  service system:  http://idphotocapture.com/support/.  This

way is preferable as the request  system  allows  to  save,  organize and easily track data.

The algorithm of creating a request in the support system is described below in Creating

a request in the support system section.

2. Via the feedback form on our website: http://idphotocapture.com/support_links/

3. Write an e-mail to the developers to the address: support@idphotocapture.com

The contents of the chapter are as follows:

Creating a request in the support system

Registration in the support system

Requests created

Creating a Request in the Support System

To create a request, please click the link: http://idphotocapture.com/support/

Then select the Submit a ticket button.

http://idphotocapture.com/support/
http://idphotocapture.com/support_links/
http://idphotocapture.com/support/
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At this stage, check the Product Support box and press Next.

In  the appeared form,  fill  in  the fields  with  your  data.  The data on the picture are given by way  of

example.

Full Name — enter your name

Email — enter the e-mail address to which you wish to receive information on this request

Priority — select request priority level

Product — select the name of the product in question.

Version — indicate the product version
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Serial  Number  —  enter  the  serial  number  of  the  product.  It  should  be  recalled  that  the  Serial

Number is indicated in the application information window located in  main menu > About.

Operation System — choose the operation system of the PC IDPhoto Processor is installed on.

If Other, please specify — if your operation system is not in the list  provided,  specify its  name in

this field. Also you need to indicate here other technical data which developers may need to answer

your request.

If the request subject is  not related to IDPhoto Processor, the Camera Model and Printer Model

fields are not to be filled in. These fields are intended to the requests related to other our products.

Subject — indicate the request subject. In the text field below, please provide a detailed description

of the question or the issue.



Chapter 9. Support

182

Add File — allows to attach screen shots or other files to the request

After having completed the input, please check the data correctness and press Submit.
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After that, the request will be accepted.

You will receive an e-mail onto the specified address, that is  to confirm registration of your request.

The letter will contain a link, click it and you'll be able to view the request status.

text

Please note that to access the request information, you need to be registered in the
support system. The registration procedure is described in more details below in the 
Registration in the support system.
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The technical support service specialists will answer your request at the earliest opportunity.

Registration in the Support System

To register in the support system, please click the link http://idphotocapture.com/support  and press the

Register button.

http://idphotocapture.com/support
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In the appeared registration form, fill in the fields with your data. The data on the picture is  given by

way of  example.  After  having completed the input,  please  check  the  data  correctness  and  press

Sign Up.
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The registration is successfully completed. To enter the support service system, please enter your e-

mail address and password in the login form, then press Login.

After that, a message confirming your signing up will be sent to the specified e-mail address.
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Requests Created

text
To access request information, you need to be registered in the support system.

To view, edit or check status of the request created, enter the system with your login and password.

Then open the View Tickets section containing all data on requests.
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You can also get access to a request via the link from the e-mail which the system sends to your e-

mail address right after creating a request.

Useful Information
Additional information that can be useful when working with identification photos as well as answers

to the most frequently asked questions can be found on our website in the Solutions chapter.
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We recommend the users of IDPhoto Processor to start from the following topics:

Identification card

Describes the systems of identification card creation.

Photo identification

Gives examples of the identification cards requiring identification photos. Also the main requirements

to the photos for documents are provided.

Facial Recognition Systems

Describes the way of facial recognition and the criteria that an image must meet in order to you

receive high-quality processing results.

Biometric Identification

This topic is about biometric methods of personal identification in images and video. Also, the

examples of tasks that may be solved with such an identification are provided.
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Conclusion
We hope that working with IDPhoto Processor will be comfortable and productive for you.

Please contacts us if

you experience problems with the IDPhoto Processor operation

you have questions, comments or suggestions in the process of using the application

you need advice on choosing a software and a hardware for working with images

We are always here to help you.

IDPhotoCapture.com

e-mail: info@idphotocapture.com

http://idphotocapture.com

mailto:info@idphotocapture.com
http://idphotocapture.com
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